10

As in this question: Ubuntu 17.10: high CPU usage by gnome-shell 3.26.1, and this question gnome-shell 3.26.1 constantly uses 20-30% CPU, I also have an issue where gnome-shell is constantly above 20% CPU, even with nothing other than terminal open:

$ top
....
 8029 xxxxxx    20  10 1714052 601696  54568 R  46.1 15.0   1179:08 gnome-shell
....

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Atom Processor 
Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

$ glxinfo | grep -i render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) Bay Trail x86/MMX/SSE2
    GL_ARB_compute_shader, GL_ARB_conditional_render_inverted, 
    GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_ARB_compute_shader, GL_ARB_conditional_render_inverted, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

I have gnome-tweak-tool installed, but I have no extensions running (I've disabled them through the menu).

Is there any way of reducing the background gnome-shell CPU usage to something sensible? At the moment I can't have a browser open, a terminal open and Dropbox syncing without the load average reaching 6+, slowing everything down.

EDIT: I've dodged the problem by logging into Unity not GNOME with Wayland or GNOME with xorg, but this is not a long-term solution, as Unity is being phased out.

1

Another solution is to upgrade all extensions (via https://extensions.gnome.org), and then to disable them one by one and see if it solves the problem. Most of the time, it comes from a faulty extension.

| improve this answer | |
  • That seems to have solved it for now. Though I don't quite understand how, when extensions weren't running. (Unless there was some other sort of conflict in gnome-shell that was causing it, which was fixed by redoing the extensions) – user36196 Jan 29 '18 at 11:20
0

Try using gnome-tweak-tool - or one of the alternatives here: How to configure GNOME 3 to show icons on desktop - to turn off 'Show Icons' on the Desktop tab.

After some months of wondering, that seems to have made an immediate difference for me.

| improve this answer | |
  • I tried this at the last reboot, and it didn't solve the issue, so still sticking with Unity(7) for now – user36196 Jan 24 '18 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.