2

I have an Asus laptop and I am using its inbuilt keyboard to type. The cursor keeps jumping from place to place while I type and sometimes it even deletes the sentences I write.

I have tried using the solutions mentioned in the link below, but unfortunately, they didn't work. https://ubuntuforums.org/showthread.php?t=2363499

sudo apt-get install xserver-xorg-input-all and sudo apt-get --purge autoremove xsuerver-xorg-input-all && sudo apt-get install xserver-xorg-input-all

Other information Ubuntu 17.10 dual boot with windows 10 intel icore 5 ASUS Q304

ram 6 Gb ram 6 GB

  • Check if your touch pad gets disabled while typing (just keep pressing any keyboard key and try to move the pointer with touch-pad, if it moves then its not disabled while typing). – Legolas Nov 14 '17 at 11:56
1

I have had that problem for years and just figured it out to night. Just go into system settings > mouse & touchpad > take the check mark out of the box for Tap to click. Violla no more mouse scurrying accross your screen when you are typing. The one pitfall is that now to click somethings is that you have to actually push on your touchpad instead of just tapping.

0

I have just run into a recurrence of this particular problem, and found an obscure post which seems to have helped my issue:

My laptop also has a touch screen (which I never use) and this is interpreted largely in the same manner as the touchpad. There seems to be some conflict in the 'disable-while-typing' routine, and I found that disabling the touchscreen fixes the issue. There is an open bug report on this issue at https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1733032

Run the command xinput to list your devices. Mine output is

xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech M315/M235                        id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD: In           id=11   [slave  keyboard (3)]

In my case, I found that disabling the 'ELAN touchscreen' with the command

xinput set-prop 10 "Device Enabled" 0

has caused the touchpad to behave in the manner I expect - namely that the device is disabled while I am typing and my palm or wrists brush against the touchpad.

-1

Sounds like your hand/thumbs are touching the touchpad while you type.
If you go into system setting there should be an option to disable the touchpad while typing.

  • Sorry this did not work, it seems the problem is especially exaggerated in text boxes inside gmail and facebook. Thanks – Aditya Lahiri Nov 11 '17 at 5:41
  • sorry frnd, it is not the case. after upgrading to ubuntu 17.10. touchpad is over sensitive. – Aravind Dec 18 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.