1

I need to disable tap to click before I go insane but I have been unable to.

I am using an HP Elitebook x360 G2 laptop. It has an Alps trackpad.

I am unable to configure it using xinput because it does not seem to be controlled by Synaptic.

Things I have tried:

Disabling it in the touchpad settings menu

xinput set-prop 15 "Synaptics Tap Action" 0 0 0 0 0 2 3

synclient TouchpadOff=2

synclient TapButton1=0

modprobe -r psmouse <-- doesn't disable my trackpad

modprobe psmouse proto=imps

sudo apt-get install xserver-xorg-input-synaptics
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-input-synaptics : Depends: xorg-input-abi-22
                                Depends: xserver-xorg-core (>= 2:1.17.99.902)
E: Unable to correct problems, you have held broken packages

All have no effect.

lsmod:

lsmod|grep -iE "apple|cyapa|sermouse|synap|psmouse|vsxx|bcm"
btbcm                  16384  2 hci_uart,btusb
bluetooth             557056  33 btrtl,hci_uart,btintel,btqca,bnep,btbcm,rfcomm,btusb
psmouse               139264  0

sudo vim /usr/share/X11/xorg.conf.d/90-libinput.conf

Section "InputDevice"    
  Identifier "touchpad"    
  Driver "libinput"    
  Option "Device" "/dev/input/event6"    
  Option "Tapping" "false"    
EndSection

xserver-xorg-input-libinput-hwe-16.04 is installed.

edit:

Device 'ALP0016:00 044E:1215':
    Device Enabled (140):   1
    Coordinate Transformation Matrix (142): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (299): -1.000000
    libinput Accel Speed Default (300): 0.000000
    libinput Accel Profiles Available (301):    1, 1
    libinput Accel Profile Enabled (302):   1, 0
    libinput Accel Profile Enabled Default (303):   1, 0
    libinput Natural Scrolling Enabled (304):   0
    libinput Natural Scrolling Enabled Default (305):   0
    libinput Send Events Modes Available (258): 1, 0
    libinput Send Events Mode Enabled (259):    0, 0
    libinput Send Events Mode Enabled Default (260):    0, 0
    libinput Left Handed Enabled (306): 0
    libinput Left Handed Enabled Default (307): 0
    libinput Scroll Methods Available (308):    0, 0, 1
    libinput Scroll Method Enabled (309):   0, 0, 0
    libinput Scroll Method Enabled Default (310):   0, 0, 0
    libinput Button Scrolling Button (311): 2
    libinput Button Scrolling Button Default (312): 2
    libinput Middle Emulation Enabled (313):    0
    libinput Middle Emulation Enabled Default (314):    0
    Device Node (261):  "/dev/input/event18"
    Device Product ID (262):    1102, 4629
    libinput Drag Lock Buttons (315):   <no items>
    libinput Horizontal Scroll Enabled (316):   1

Found the mouse. However, tap to click is not a setting.

0

The answer is that you can't. The touchpad is managed by some unconfigurable microcontroller embedded in the hardware and is read as a PS/2 mouse by the OS. I have yet to test whether changing the settings in Windows carry over to Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.