1

Recently I installed Ubuntu 17.10 on my ThinkPad T530.But I have a problem (and I know how much ThinkPad hardware is supported on the linux world).So If I close the lid,the thing won't get on sleep mode.I'm worried because it might be a hardware problem.So my questions are:

1.Did somebody tested Ubuntu on a T530/T430 and does the auto sleep when close the lid?

2.How can I fix it? I already tried to change /etc/systemd/logind.conf

Any help is appreciated Thanks

  • I have a Vanilla Ubuntu with Gnome – tuddyftw Nov 10 '17 at 20:50
  • Use dconf-editor to check /org/gnome/settings-daemon/plugins/power/.. lid-close-ac-action and lid-close-battery-action. These should both be suspend by default, but you never know. – chaskes Nov 10 '17 at 20:53
  • Glad it worked out. I made an answer. Please accept when you have a chance. – chaskes Nov 10 '17 at 21:29
  • This answer solved my problem. I hope it works for you too askubuntu.com/questions/972169/… – Bogdan Tabacaru Nov 11 '17 at 16:00
1

Use dconf-editor to change the settings:

/org/gnome/settings-daemon/plugins/power/lid-close-ac-action
/org/gnome/settings-daemon/plugins/power/lid-close-battery-action

to 'suspend' (Note: the single quotes are required in the setting.)

In a default Ubuntu install, these would be set to 'suspend' by default, but the vanilla desktop does not apparently do that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.