1

enter image description hereI have started using the terminator emulator, and overall it's great. One annoying issue I have however, is that everytime I open up vim inside of it the window acts very odd. Basically all the symbols get wacky and it's illegible. Even doing screen redraw doesn't help.

However, if I open one addition terminal window , the original window with Vim inside goes back to normal. I'd like to not always open a new window for Vim to work, so i'm hoping someone has perhaps had a similar issue.

I think be a vimrc setting that's off. I could put part of it up if that would help. Thanks

Here's some of the vimrc file:

"source $VIMRUNTIME/vimrc_example.vim
"source $VIMRUNTIME/mswin.vim
"behave mswin

nmap <F8> :TagbarToggle<CR>


"set t_Co=256
" Let's set the wrap margin

" This line should not be removed as it ensures that various options are
" properly set to work with the Vim-related packages available in Debian.
" runtime! debian.vim

filetype plugin on
set hlsearch

"set foldmethod=syntax
"set foldnestmax=1


"set shellcmdflag=-ic


autocmd  BufRead,BufNewFile /tmp/calcurse* set filetype=tex
autocmd BufRead,BufNewFile ~/.calcurse/notes/* set filetype=tex

"if has('gui_running')
"  set guifont=Lucida_Console:h11
"endif

"set termguicolors


set grepprg=grep\ -nH\ $*
"set t_ut=

"set background=light ## Heading ##
"syntax enable 
"let g:solarized_termcolors=16

"colo desert

" Setting up the relative numbering feature.
set relativenumber 

set foldlevelstart=99

set nocompatible

set shellslash

"innoremap <expr><buffer><silent> gb  ':!zathura --synctex-forward 
'.line(".").':'.col('.').':% ' . 
shellescape(g:latex#data[b:latex.id].out()) . ' >/dev/null<CR>'
let g:livepreview_previewer = 'zathura'
nmap <F12> :LLPStartPreview<cr>

set sw=8

let mapleader=','
"filtetype indent on


set ttimeout



let g:tex_flavor ='pdflatex'

let g:Tex_DefaultTargetFormat ='pdf'

let g:Tex_CompileRule_pdf = 'pdflatex -synctex=1 -
interaction=nonstopmode $*'

let g:Tex_ViewRule_pdf = 'zathura'



"let g:Tex_CompileRule_dvi = 'latex --interaction=nonstopmode $*'
"let g:Tex_CompileRule_dvi = 'latex -interaction=nonstopmode  $*'
  • Need more information. Which version are you suing? Are you at the console, or is this over a ssh connection? – SDsolar Nov 10 '17 at 17:55
  • I'm not sure what version. I think I am at the console but I don't know much about linux still. I use I3window manager over ubuntu and I used to use the standard terminal emulator that comes with ubuntu. Then I installed terminator using the command line. So now when I do the keypress in i3 to bring up a terminal terminator comes up. – Jmaff Nov 10 '17 at 17:59
  • 1
    It's really hard to imagine what "acts very odd", "all the symbols", "get wacky" etc. mean. Could you post a screenshot or screencast? – egmont Nov 10 '17 at 20:30
  • If you think there's something wrong with your vimrc file, do you mind attaching its content to your question? – dessert Nov 10 '17 at 22:17
  • Thanks. I was trying to take a screenshot inside of the i3 window manager and couldn't figure out how. I then tried to take a screenshot from within Ubuntu but there the issue (as I just saw) does not come up. @egmont by get wacky I mean that: as I scroll down or start typing much of the text disappears (these are non empty tex files) and only randomw characters are left on the screen. When I hit <C-L> the screen redraws but when I start typing again the same issue occurs. As I said the fix so far is to open a new terminal and immediately close to. – Jmaff Nov 11 '17 at 1:49
-2

Thank you for posting this question! I am using this every day now.


You can find out the version of Ubuntu you are using with this command:

lsb_release -a

Under Ubuntu 16.04 LTS terminator installs like so:

sudo apt-get update
sudo apt-get install terminator

and run by typing:

terminator

vim can be installed from inside the terminator window

sudo apt-get update
sudo apt-get install vim

and run it by typing

vim
  • It works just fine. Nothing strange about it at all.

You can open a window to the right with Ctrl+Shift+E

And another just below it with Ctrl+Shift+O

  • vim works fine in all of them.

Ctrl+Shift+W closes the "current window" which you can select with your mouse.


Also, if you right-click inside a window it gives the options to split it horizontally or vertically or close it.


Here is an example of using vim in the top screen.

/home/pi/.vimrc looks like this:

syntax enable
set number
set ts=4
set autoindent
set expandtab
set shiftwidth=4
set cursorline
set showmatch
let python_highlight_all = 1

enter image description here


Regurlarly I monitor my cron activity by opening one window below

(Ctrl+Shift+O)

wcron

to get my real-time cron log monitor running, as per:

16.04: How do I make cron create cron.log and monitor it in real time?


Then in this example I have wcron in the bottom part, and above it I ran a script that went out to the OUTSIDE data-logger to run an rsync back to the hard drive of the mothership.

enter image description here


This is great. Makes the Ubuntu experience much more rich on a single monitor.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.