9

I just installed ubuntu 17.10. I'm using a Ryzen 1200 CPU and an RX-560 GPU with a 2580x1080 60Hz monitor.

The monitor is connected to the GPU through an HDMI cable.

When I'm using the native monitor resolution of 2580x1080, in the wayland session, the screen makes these very weird glitches. The glitches look like a refresh rate issue, one that is fixed by v-sync, but they are very intense and on the whole screen. As soon as I change the resolution to a lower one the screen becomes normal.

In the x.org session I can use whatever resolution I want, everything works great.

The problem is that during the boot-loading screen (the one that says "ubuntu") and at the login screen I see the same glitches on the screen until I login.

Is the boot-loading-indicator using wayland? Can I make it use x.org/x11? The same for the login screen?

13

You need to edit /etc/gdm3/custom.conf, change this line:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

to

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false
  • 1
  • True, still answered here, so people having only this question find it easily. Btw. if you believe the question to be a duplicate of an existing question you should flag the question for that. – Videonauth Nov 10 '17 at 15:56
0

When logging in you, when you select your username (account) from the login screen, a small gear will appear below the login box. Select the gear and select Ubuntu from Xorg. This is a quick and easy way to set this and also set it back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.