9

I am using Ubuntu 16.04 LTS.

Today I tried to open the Skype, after providing the login credentials, automatically Skype got terminated.

One day before Skype was working properly.

Once I tried to open the Skype from the terminal, got the below error message:

deepak@deepak:~$ skype Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "gail" Gtk-Message: Failed to load module "atk-bridge" Gtk-Message: Failed to load module "unity-gtk-module"

  • sir i have a bunch of questions that can easily resumee into one, how do you installed skype? (explain detailed, if you don't remember delete this post(joke)) – Egon Stetmann. Nov 10 '17 at 14:15
  • You can install from the ubuntu software center. – Deepak Singh Nov 10 '17 at 14:17
  • so you installed from the software center... that explains your problem – Egon Stetmann. Nov 10 '17 at 14:36
  • But it was working today morning and without installing any package or updating any package how it stopped working? – Deepak Singh Nov 10 '17 at 14:49
  • 1
    Micro$oft just updated Skype, adding some features <cough>bloat<cough>, so it's supposed to pop up a window telling you to upgrade to the newest version, but 9/10 it crashes (trial and error on my part). Nothing to do with gail and atk-bridge, imho, just bad coding on MS's part. – user303371 Nov 24 '17 at 1:37
11

I don't trust the black magick that makes the software center, in cases like this.
Remember, with linux things... the CLI is your best friend. :)

First you need to delete that buggy skype so open a terminal with CTR + ALT + T
And type the following...
Note: I'm assuming that your package is called skype since you copy-pasted that here

sudo apt purge skype --auto-remove

Now go and download a fresh copy of Skype from the oficial website.
When you completed the download, go to the folder and right click 'open terminal'.
then you must type the following commands...
Note: use TAB for autocompleting the annoying large name of the package

sudo dpkg -i skype-amd64.deb
sudo apt install -f

With that done, your skype should work fine. If for some weird reason the installation gives you errors, then do sudo apt update && dist-upgrade for fixing missing libraries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.