0

I set up a new ubuntu 17.10 and installed dolphin from Ubuntu software. When I do a search ('find'), after typing a few characters a message shows up 'invalid protocol'. Any packages missing to be installed?

  • 1
    I had this problem with KDE on 16.04. Dolphin needs the Baloo indexing package in order to do searches. Indexing can be turned off, but the package needs to be installed. – ravery Nov 9 '17 at 13:46
  • Baloo is installed. Must be some other reason. – Hein Bloed Nov 10 '17 at 15:09
  • I started Dolphin in terminal. Then performed a search which resulted in 'invalid protocol'. Here is the output of the terminal: Invalid Context= "stock" line for icon theme: "/usr/share/icons/ubuntu-mono-dark/stock/128/" Trying to convert empty KLocalizedString to QString. qt.accessibility.core: Cannot create accessible child interface for object: PlacesView(0x5587b72b7330) index: 23 kf5.kio.core: couldn't create slave: "klauncher said: Unknown protocol 'filenamesearch'.\n" – Hein Bloed Nov 10 '17 at 16:45
0

You could try the instructions here: https://www.ryananddebi.com/2015/07/13/linux-getting-find-working-in-dolphin-on-kde-linux-mint-and-kubuntu/

In short install kde-baseapps, systemsettings and kfind. And DISABLE "Enable Desktop Search" in Systemsettings -> Desktop Search. It should work then. It did for me. Pretty counterintuitive but it works ;).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.