8

I am using ubuntu 16.04 on my HP 15 ab522tx laptop.Even after I shut down my pc after few hours I find it discharged completely .Also,battery is quite new and was performing better in previous OS(windows 10).

I also tried various power saving workarounds but I am not able to figure out why this happens!Please explain.

Is there any solution for this!

Output of systemd-inhibit --list :

hemant@hpnb:~$ systemd-inhibit --list
     Who: NetworkManager (UID 0/root, PID 1258/NetworkManager)
    What: sleep
     Why: NetworkManager needs to turn off networks
    Mode: delay

     Who: Telepathy (UID 1000/hemant, PID 3222/mission-control)
    What: shutdown:sleep
     Why: Disconnecting IM accounts before suspend/shutdown...
    Mode: delay

     Who: Unity (UID 1000/hemant, PID 2637/compiz)
    What: sleep
     Why: Unity needs to lock the screen
    Mode: delay

     Who: hemant (UID 1000/hemant, PID 2569/unity-settings-)
    What: handle-power-key:handle-suspend-key:handle-hibernate-key
     Why: GNOME handling keypresses
    Mode: block

     Who: hemant (UID 1000/hemant, PID 2569/unity-settings-)
    What: sleep
     Why: GNOME needs to lock the screen
    Mode: delay

5 inhibitors listed.
6
  • Can you confirm that your system is shut down completely? Complete shut down can be ensured by checking if turning on again shows the boot screen and grub boot loader
    – Yaksha
    Nov 9 '17 at 8:44
  • @Yaksha I m 100% sure. :) Nov 9 '17 at 9:17
  • Please run the following command in a terminal and edit your question with the output.
    – J. Starnes
    Nov 11 '17 at 20:37
  • 2
    Goodness I forgot the command. systemd-inhibit --list will list all programs that are blocking or delaying shutdown commands.
    – J. Starnes
    Nov 11 '17 at 21:12
  • 2
    If your machine is actually powered off, I do not see how this can be about Ubuntu, as Ubuntu could not be running at that point. It sounds like a hardware issue. Can you remove the battery easily? If so, next time you shut down the machine, remove the battery and set it aside for a few hours. Then plug it in and see what the charge rate is. If the battery still discharged, it is a problem with the battery. If not, likely some other issue in the hardware.
    – dobey
    Nov 11 '17 at 21:23
3
+100

Remove the battery for several hours and check if it will drain out. If the battery still charged, it should be healthy.

One possible trouble maker could be any USB port or other device that still powered while the system is shut down.

Extra powered USBs are feature for some laptops. Usually these ports are yellow colored. Port as this could be troublemaker especially if something is plugged in this port. In most cases this feature could be disabled via the BIOS settings.

Recently I've discovered that the new batteries should be charged to 100%. Unfortunately I can't find the source of this statement but this solve my problem with my new battery jump drain from ~35% to 5%.


Within Ubuntu the package tlp (apply laptop power management settings) could be helpful. It is capable to handle the power management of the devices (USB, PCI, etc.) at kernel level.

TLP [1] brings you the benefits of advanced power management for Linux without the need to understand every technical detail. TLP comes with a default configuration already optimized for battery life, so you may just install and forget it. Nevertheless TLP is highly customizable to fulfil your specific requirements.

Please note: TLP runs on every laptop brand. Setting the battery charge thresholds is available for IBM/Lenovo ThinkPads only.

TLP is a pure command line tool with automated background tasks. It does not contain a GUI.

TLP [2] (TLP - Linux Advanced Power Management) is more progressive management utility battery-for Linux, which applies different settings automatically when you log on and every time you change the power source, depending on your distro and hardware.

Basic usage of tlp:

  • Install the package: sudo apt update && sudo apt install tlp.

    If you are using tp-smapi the better way to install the package is:

    sudo add-apt-repository ppa:linrunner/tlp
    sudo apt-get update
    sudo apt-get install tlp tlp-rdw
    sudo apt-get install tp-smapi-dkms acpi-call-dkms
    
  • There are two services installed tlp.service and tlp-sleep.service.

  • Use sudo tlp stat to check the current settings.

  • Use nano /etc/default/tlp to tweak the configuration.

  • Use sudo tlp start to apply the configuration.


Another useful tool is powertop, that is not just a monitoring tool, but has also a calibrating option: powertop -c.


4
  • IMO in nowadays systems (where is not presented a hardware ON/OFF switch like into the systems from the 80s) the operating system could play a significant role when the system is shut down. For example on my ThinkPad X230, while within tlp the battery stop threshold is set to 80%, this stop threshold still active while the laptop is power off.
    – pa4080
    Nov 20 '17 at 7:11
  • Another 100 point bounty on this same question here: askubuntu.com/questions/1022899/… Apr 12 '18 at 1:28
  • Thank you for this note, @WinEunuuchs2Unix.
    – pa4080
    Apr 12 '18 at 10:13
  • Just a reference to a related question: Ubuntu 18.04 battery life
    – pa4080
    Oct 18 '18 at 9:19
2

Trouble shooting for software problems.

Run and examine the output of 'systemd-inhibit --list' for any abnormal inhibiting programs. You can kill the listed processes to test if they are the cause. In your case none of the inhibiting processes appear to be abnormal.

Activate sendsigs report_unkillable config option, from this answer by falconer. Repoduced here for clarity.

  1. Open /etc/init.d/sendsigs in your favourite text editor, with root privileges (e.g sudo vi /etc/init.d/sendsigs or gksu /etc/init.d/sendsigs). Search for the line #report_unkillable and uncomment it (i.e. remove the # tag). Save the file.

  2. Make sure that apport is enabled: Edit the file /etc/default/apport so it reads enabled=1. (If it was enabled=0 then reboot, so apport can start.)

  3. Shutdown.

  4. Upon the next boot apport should come up with a message telling you that there was some kind of problem with a program. That is the one causing the delay. And there should be a crash report in /var/crash . (If apport doesn't report the name, then just look in the crash file, in the end of the file there will be something like Title: MISBEHAVING_PROGRAMNAME does not terminate at computer shutdown)

1

I had exat same problem in my hp laptop running ubuntu ,the problem was WOL(wake on LAN) Wake on LAN is enabled by default and you cannot disable it in your BIOS/UEFI because the setting is not available. On notebooks/ultrabooks, WOL can drain/discharge your battery even your device is powered-off! follow this page "https://andidittrich.de/2015/12/ubuntu-15-10-disable-wake-on-lan-wol-permanently.html"

1
  • 1
    try to include what you think is important from the link in your answer instead, as your answer will be invalid if the link goes down May 19 '18 at 16:57
1

After trying everything on the internet, what worked for me was installing TLP and:

  1. Setting BlueTooth, WiFi, and WWAN to disable on shutdown

    tlp-settings-1

  2. Enabling USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN

    tlp-settings-2

0

Solved for me (HP Spectre) by updating BIOS via Windows:

https://support.hp.com/us-en/document/c00042629

-2

Are you sure your battery hasn't just begun to enter ill health. You need to charge it fully and drop test it to see if there is good current holding capacity. remember Li-ion have a memory effect and should be charged for 24 hours from new without switching the device on. My laptop when fully charged reports theres 10 and a half hours of usage this is nearer 3 hours and it still trickle leaks when switched off so i have to plug it into the charger every time i want to boot from a long cold period.

2
  • 2
    Lithium Ion batteries do not have memory effect, not at this stage at least. Discharging it to low percentages does more harm than good.
    – Yaksha
    Nov 12 '17 at 9:39
  • Drop testing a battery doesn't discharge it that's not what i'm recommending. To Drop test a battery, you briefly short it out with a voltmeter across it. if the battery is in good health the volt meter's reading won't change. DO NOT short the battery for more than a couple of seconds
    – rhubarbdog
    Nov 13 '17 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.