2

Please I need some help, I barely know and very new Ubuntu user. I'm trying to upgrade from 14.04.4 LTS to 16.04.3 LTS by using

do-release-upgrade

but it fails and I got that error message

    Traceback (most recent call last):
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/xenial", line 8, in <module>
    sys.exit(main())
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/DistUpgradeMain.py", line 239, in main
    save_system_state(logdir)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/DistUpgradeMain.py", line 131, in save_system_state
    scrub_sources=True)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/apt_clone.py", line 149, in save_state
    self._write_state_installed_pkgs(sourcedir, tar)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/apt_clone.py", line 203, in _write_state_installed_pkgs
    import lsb_release
ImportError: No module named 'lsb_release'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/problem_report.py", line 416, in add_to_existing
    self.write(f)
  File "/usr/lib/python3/dist-packages/problem_report.py", line 369, in write
    block = f.read(1048576)
  File "/usr/lib/python3.4/codecs.py", line 319, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0x8b in position 1: invalid start byte

Original exception was:
Traceback (most recent call last):
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/xenial", line 8, in <module>
    sys.exit(main())
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/DistUpgradeMain.py", line 239, in main
    save_system_state(logdir)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/DistUpgradeMain.py", line 131, in save_system_state
    scrub_sources=True)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/apt_clone.py", line 149, in save_state
    self._write_state_installed_pkgs(sourcedir, tar)
  File "/tmp/ubuntu-release-upgrader-i_2c0bda/DistUpgrade/apt_clone.py", line 203, in _write_state_installed_pkgs
    import lsb_release
ImportError: No module named 'lsb_release'
=== Command detached from window (Thu Nov  9 11:20:21 2017) ===

What should I do to fix to successful complete upgrade the released?

Thanks in advanced.

3

I did search for lsb_release module with dpkg -S lsb_release | grep python on my Ubuntu 16.04.3 LTS and got its package (lsb-release). In Trusty it is located in the same package.

So for me it seems that you should install this package before upgrade with
sudo apt-get install lsb-release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.