My computer doesn't boot. I format my Toshiba laptop with a bootable USB drive. I make this my_partitions, and when i restart the computer after the installation, my computer does not boot. Then i run boot-repair and finishes with this message. I reboot ant nothing happens. I review some questions before, but could't find anything yet. Can someone help me please?

  • You don't appear to be asking a question.
    – psusi
    Nov 9, 2017 at 2:49
  • After the installation, Ubuntu won't boot, just the bootable usb drive. I run boot-repair and this is what i got paste.ubuntu.com/25923375
    – mau
    Nov 9, 2017 at 6:59
  • @psusi can you help me?
    – mau
    Nov 9, 2017 at 7:06
  • 1
    @psusi - the question is, how do you "make your BIOS boot on sda6/EFI/ubuntu/shimx64.efi file!"? That's not the type of thing that's shown up in any BIOS I've seen.
    – Ben Creasy
    Oct 7, 2018 at 7:11
  • The answer to my above question is probably to run something like efibootmgr --create --disk /dev/sda --part 1 --loader /EFI/refind/refind_x64.efi --label "rEFInd Boot Manager" --verbose (seen at wiki.archlinux.org/index.php/…)
    – Ben Creasy
    Oct 24, 2018 at 0:14

1 Answer 1


There is a blog post discussing this at http://adityagilra.blogspot.com/2014/11/fixing-ubuntu-boot-problems-with-boot.html

"""You can now reboot your computer. Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/grubx64.efi file!""" I think they just mean that: enable UEFI and set the boot order to first boot HDD in the BIOS.

But you can check using efibootmgr:

I installed efibootmgr using synaptic. (see http://ubuntuforums.org/showthread.php?t=2023086)

(If you're not root, use sudo efibootmgr -v can become root by sudo su -) root@ubuntu:~# efibootmgr -v BootOrder: 0000,0000,0000,0000 Boot0000* ubuntu HD(1,22,2faf1,d6f60eae-849f-43e3-836c-2280067f3161)File(\EFI\ubuntu\shimx64.efi)

According to What is the difference between grubx64 and shimx64? shimx64.efi is for Secure Boot.

As noted at the Arch Boot Process:

A boot entry could simply be a disk. In this case the firmware looks for an EFI system partition on that disk and tries to find a EFI application in the fallback boot path \EFI\BOOT\BOOTX64.EFI (BOOTIA32.EFI on IA32 (32-bit) EFI systems). This is how UEFI bootable removable media work.

Honestly, the warning message should probably be removed from that boot-repair utility, altho I'm not so sure it's well-maintained.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.