0

I just downloaded Eclipse Neon for Ubuntu 16.04, but when I run the eclipse executable, I have some error (see http://paste.ubuntu.com/25918638/). How shall I solve the problem?

I have installed Oracle's JVM, JRE, and maybe also JDK (I don't know how to verify that) since a few months ago. Does Eclipse have problem working with the preinstalled JVM, JRE and maybe also JDK?

Thanks.

  • What version of java are you using? – George Udosen Nov 8 '17 at 17:19
  • java.version=9-ea and java.vendor=Oracle Corporation – karel Jan 3 '18 at 9:30
0

You are using Java 9. Eclipse Neon does not run with Java 9 unless you modify the eclipse.ini, and even when you do that it does not support Java 9 language features.

The current release of Eclipse is Oxygen.1a (4.7.1a). This is the first release of Eclipse to fully support Java 9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.