1

I have been trying to install virtualbox extension pack. so I downloaded its file from the http://www.virtualbox.org and i ran it. but I encountered the following error:

Failed to install the Extension Pack
/home/waezi/www/Oracle_VM_VirtualBox_Extension_Pack-5.2.0-118431.vbox-extpack.VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='VirtualBox version mismatch - expected 5.2 got 5.1'.
Result Code: NS_ERROR_FAILURE (0x80004005) Component: ExtPackManagerWrap Interface: IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}

I have to mention that I am connecting from Iran.

anybody can help???!!!!

  • The extension pack you have isn't for the Virtualbox version you have installed please check the version specific to your Virtualbox install. What Virtualbox version are you using? – George Udosen Nov 8 '17 at 7:33
  • use can use sudo apt install virtualbox-ext-pack to install the extension pack. – neferpitou Nov 8 '17 at 8:23
2

The extension pack that you downloaded is for a different, later version of VirtualBox (v5.2) than the one currently installed on the system in question (v5.1). You need to either

  • upgrade the VirtualBox installation to v5.2 or
  • download and install the extension pack for v5.1.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.