Sorry for the English mistakes, I'm Spanish.

I have a tablet with ubuntu 11.10 completely updated. Sometimes it takes about 35 seconds to boot, I suppose it's a right time.

However, there are LOTS of times which takes about 2 minutes. The screen is black about 100 sconds without any message. Unfortunately this happens very often and randomly: maybe there are 3 wrong times, then 1 right one, 8 wrong, 3 right, 1 wrong, 2 right... No pattern at all.

I copy the results of dmesg command in a 'good' and 'bad' boot:

EDIT: Thanks to Rinzwind and JanC,I've investigated and the booting issue appears always at the same point:

[ less than 1 second] pci 0000:00:02.0: Boot video device [ 98 seconds before] PCI: CLS 64 bytes, default 64

Hola, poseo una tableta con ubuntu 11.10 completamente actualizado. En ocasiones tarda 35 segundos en arrancar, imagino que es un tiempo normal de arranque.

Sin embargo MUY a menudo tarda 2 minutos en arrancar. Después de encender la tableta la pantalla se queda negra durante aproximadamente 100 segundos. Por desgracia esto ocurre muy a menudo y de forma aleatoria: por ejemplo 3 arranques malos, 1 bueno, 8 malos, 3 buenos, 1 malo, 2 buenos... No sigue ningún patrón.

Copio los resultados del comando dmesg en un arranque 'bueno' y uno 'malo':

EDITO: Gracias a Rinzwind y JanC, he investigado y el error aparece siempre en el mismo sitio:

[ less than 1 second] pci 0000:00:02.0: Boot video device [ 98 seconds before] PCI: CLS 64 bytes, default 64

  • 1
    Install bootchart and compare a normal boot with a long boot! it will 100% tell you what file is causing it and thus what service. – Rinzwind Jan 21 '12 at 17:01
  • 1
    From what I can see, it looks like there might be an issue with "booting" the graphics device (0.5 seconds on a good boot, 98 second on a bad one). – JanC Jan 21 '12 at 18:19
  • Thanks, I've updated the information with bootcharts results in my previous message. Can you help me? – David López Jan 23 '12 at 19:20
  • A kernel update solved the problem. – David López Feb 15 '12 at 0:36
  • 2
    Congrats on solving the problem, can you please write a answer your question instead of editing it? Thanks. :) – jrg Feb 15 '12 at 1:03

I've solved the problem. The iso I used to install ubuntu was not the 'official' release, it was made by a company to adapt Canonical's to tablets. The modified iso blocked kernel updates: I remove the blocking, I update to kernel 3.0.0-16 and the problem dissapear.

He resuelto el problema. La iso que usé para instalar ubuntu no era la oficial, sino una modificada por una empresa para adaptarla a la tableta. Esta iso modificada impedía las actualizaciones del kernel: eliminé ese bloqueo, actualicé al kernel 3.0.0-16 y se solucionó el problema.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.