Asus Zenbook UX550, running Ubuntu Gnome 17.04.

Like the title says, my volume is either max or muted. I tried following this, but nothing helped. In fact, prior to applying that fix, I could hear the volume indicator noises, now I can't even hear those. (By indicator noises, I mean those beeps that are made when adjusting the volume via keyboard).

2 Answers 2


I have the same laptop and couldn't get volume control work well for a long time. Any level of volume was at the highest volume of the laptop speakers so I used it always on mute. This issue only affected speakers and not headphones (from plug or bluetooth).

I found a working solution based on this answer:

  1. Edit the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common (with sudo):

sudo vi /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

  1. Add the following lines before the [Element PCM] block:

[Element Master] switch = mute volume = ignore

  1. Kill the running daemon:

pulseaudio -k

After this steps I got the volume level working for my speakers. I assume a new daemon started automatically after killing the runnig daemon. If the daemon does not start, try to start it manually with:

pulseaudio -D

Hope this helps!

  • This recommendation has also worked on my ASUS Zenbook UM-431 laptop. Thanks @manuelmatas! It was helpfull! Jul 1, 2020 at 10:40
  • Also confirmed for Zenbook UX490UA using Mint 20
    – user513183
    Aug 4, 2020 at 20:10
  • Works on my Asus Zenbook UX430 as well. Thank you so much!!
    – Anis R.
    Dec 11, 2020 at 22:48
  • Works perfect on Asus ROG Strix G17 G712LW. Many thanks
    – tenta4
    Feb 24, 2021 at 10:27
  • Does not work on Asus rog strix
    – rvimieiro
    Apr 7 at 20:21

I had the same issue on my UX550 until I activated two bottom speakers.

apt install alsa-tools-gui


Select a codec: Realtek ALC295

Click Show unconnected pins

Then you need to override Pin ID: 0x1b and Pin ID: 0x1e and select Internal speaker (Back) or Internal speaker (LFE) - I didn't noticed any difference between them.

Next click Apply now and Install boot override.

  • 1
    This fixed my issue as well! However, whenever I plug in headphones, all I hear is a repeating popping sound. Did you experience anything similar? Any idea how to fix that?
    – Pavlin
    Jan 18, 2018 at 21:20
  • No, I didn't have such issue with my headphones. But I'm using Linux Mint 18.3, maybe that's the reason.
    – Optiman
    Jan 19, 2018 at 10:43
  • How did you come up with these settings? I get no sound with these settings on UX550VD.
    – rustyx
    Oct 5, 2021 at 14:41
  • @rustyx I noticed, that only 2 out of 4 speakers were active. So I launched the hdajackretask and activated all other "Internal speakers" that the GUI showed. That's it.
    – Optiman
    Oct 6, 2021 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.