I have made fresh install of Ubuntu 17.10 (fresh, except keeping my old /home partition). Everything seams to work out of the box except after I installed (or actually enable in Additional drivers) the nVidia 384.90 driver system failed to start. I was just getting following error

[ OK ] Started NVIDIA Persistence Daemon.
Stopping NVIDIA Persistence Daemon...
[ OK ] Stopped NVIDIA Persistence Daemon.
Starting NVIDIA Persistence Daemon...

And this goes all over again and again like hundred times and the just stops. The only way out is uninstalling nvidia-384 using recovery mode.

I have tried other versions of the driver as well but with very same result. On shared Intel graphics (Intel® Haswell Mobile) everything works fine.

My config:

Intel i7-4710MQ
nVidia GT 940M

5 Answers 5


Switch to Discrete Graphics on BIOS

Lenovo P51, UEFI BIOS Version N1UE40W, NVIDIA Quadro M1200 Mobile, Ubuntu 17.10, nvidia-384 installed from software-properties-gtk:

  • Hit Enter at boot time
  • Press F1 for BIOS setup
  • Config
    • Graphics Device
    • Select Discrete Graphics (Default was hybrid graphics)
  • Security
    • Secure Boot
    • Secure Boot
    • Select Disabled (Default enabled). If I don't do this, the NVIDIA driver simply gets ignored (and the boot problem does not happen either)
  • Press F10 to save settings and exit boot menu

I think this makes the battery last less, but I'd rather have a desktop :-)

I also noticed that the problem is not reproducible every time. If I power cycle a few times, I also see the following behaviours:

  • immediate computer restart during boot
  • once everything actually worked

Then check that the GPU is actually being used: How do I check if Ubuntu is using my NVIDIA graphics card?

Possible launchpad bug for this: https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1714881

  • 1
    For me on a Dell latitude this was in the graphics menu in BIOS and something to do with enabling Optimus, it says only supports windows but solved the problem in ubuntu 18.04 thanks for the point in the right direction Jan 2, 2019 at 7:05
  • I have the same laptop and only hybrid graphics seems to work. It may have to do with which mode prime-select is on
    – qwr
    Jun 5, 2021 at 3:58
$sudo apt-get purge nvidia*  

will work fine. Once the system gets started install the compatible driver.

  • I had to do ` sudo apt autoremove` after this command in order to remove the cuda packages too in order to do a clean install
    – Butanium
    Mar 27, 2023 at 16:52

I do not know the cause for this behaviour but I have the same problem on my ASUS laptop with GM108M [GeForce 840M]. My improvised solution is to disable automatic login. If I do login manually I have the normal startup. I use the proprietary driver.

  • I had automatic login disabled and it didn't work. Did you have the very same problem as me with the Persistence Daemon? Nov 13, 2017 at 15:07
  • Yes, I did and still do. Each time I start with the automatic login enabled I get the message you posted and after a couple of seconds my computer stops. So I restart with an older kernel, the automatic login goes normally, then I change to manual login, restart again by default and the laptop boot without any problem. It seems it has to do with the new kernel.
    – MartinH
    Nov 14, 2017 at 22:10

Consider changing your display manager to lightdm. gdm3 doesn't work very well with nvidia drivers in my experience. I can not get it work at all if I'm using the modeset driver (and I've been trying for months). There are no workarounds that I have found. Nvidia, gdm3 and modern gnome are broken on both of my Optimus Thinkpads, you have to change one of those three, and the easiest is to replace gdm3 (if you change from gnome to another desktop environment, you will probably end up with lightdm anyway).

You are not trying to use modeset so you don't experience the same problem, but I have become biased against the unholy trinity of nvidia graphics, gnome and gdm3.

I have no problems with lightdm

sudo apt install lightdm

if necessary

sudo dpkg-reconfigure lightdm

and set it to the default (the installation of lightdm will ask you, but not if you already had it installed).

If you can't log in, you may feel a bit stuck. Hopefully you still have that old kernel. Otherwise you will have to try the advanced option and boot into recovery mode. I find that I choose 'enable networking' I usually get to a root shell in read/write which lets me do apt get stuff. If that doesn't work, it gets a bit harder; you can either reinstall or boot from a livecd and learn how to use chroot to do a pretend-login to your main installation. (something very useful to know).


This answer actually did the job for me. None of the above solutions were applicable for me.

It all comes down to disabling the default startup of the nvidia persistence daemon and writing an own systemd service which starts on boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .