I have an Ubuntu 16 Server at my home, everything running smoothly even installed webmin to ease my work with some configurations but now I want to install a timemachine server on it and seems that I'm stuck on restarting the netatalk service.

It gives me the following error

Failed to start netatalk.service: Unit netatalk.service is masked.

The first thing I've tried was uninstall the netatalk package a reinstall it, then I tried disable the service and refresh the daemon it didn't work either.

The tutorial that I followed is this one

Use Ubuntu network share for Apple TimeMachine backups?

I want to avoid reseting my system and I no longer can figure out what to do.

Don't know if this helps, but here's the status output

pedro@HITMAN-SERVER:~$ sudo service netatalk status

● netatalk.service

Loaded: masked (/dev/null; bad)

Active: inactive (dead)

Any ideas?

Thanks in advance

==== EDIT ====

After George idea I was able to remove the symlink giving this status

pedro@HITMAN-SERVER:/lib/systemd/system$ sudo systemctl status netatalk

● netatalk.service

Loaded: not-found (Reason: No such file or directory)

Active: inactive (dead)

There should be a file called netatalk.service in the folder /lib/systemd/system that by removing said file the service should disappear from the system but I can not find the file and I believe that because the service is still being detected the apt-get install netatalk does not configure the service correctly

I've placed a search on my system for the netatalk.service and removed (created backup) of said files and rebooted the computer... The service still appears on systemctl

  • Please try sudo unmask netatalk, then do systemctl status netatalk and see if it removes the link to /dev/null Nov 5, 2017 at 17:24
  • 1
    Partially solved. it removed the mask but the service is still there. I had to make a change in the first command though it is sudo systemctl unmask netatalk. Nov 5, 2017 at 22:04
  • Yes that change was in order Nov 6, 2017 at 10:09

1 Answer 1


After the George's help and a bit more of search I was able to properly run netatalk.

The correct steps that I took to fix the problem are the following

As George said

sudo systemctl unmask netatalk

This will unmasked the /dev/null of the service.

Then I just followed the installation guide bellow instead of using the apt-get command


hope this helps other people with similar problems

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .