1

(edit) Topic closed:
It wasn't a problem with jackdbus auto.
In this thread I accidentally found a hint that, without me noticing, the server name changed itself from "(default)" to "voreingestellt" (, which is german for "default".)


Preabmle:
I'm running Xubuntu 16.04.3 LTS xenial Kernel: 4.4.0 Lowlatency

Problem:
It all starts with the error

Ignoring JACK server start request because server is already started.

when I want to start the PulseAudio Bridge in Cadence.
I had this before and killing jackdbus auto allowed me to start a fresh instance and got it working (as fragile and unstable as jack works then). However, I am absolutely unable to kill jackdbus auto, no matter what I do.

  1. Taskmanager > right-click > kill
  2. kill pid
  3. kill -9 pid
  4. killall jackdbus
  5. killall -9 jackdbus

2 and 4 do absolutely nothing.
1, 3 and 5 cause the process to be killed but being auto started again right away with a new pid.
Since it's called jackdbus auto I can assume that it starts automatically but how in the world am I supposed to solve the error/message when trying to start PulseAudio Bridge in Cadence?

2
  • try sudo systemctl stop jackdbus, then sudo systemctl disable jackdbus Nov 5, 2017 at 17:40
  • 1
    @George foobar@linux:~$ sudo systemctl stop jackdbus Failed to stop jackdbus.service: Unit jackdbus.service not loaded. foobar@linux:~$ sudo systemctl disable jackdbus Failed to execute operation: No such file or directory
    – antimatter
    Nov 5, 2017 at 18:31

1 Answer 1

2

/etc/pulse/default.pa contains

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

You can comment those lines out and that should prevent auto-loading to jackdbus by Pulse Audio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.