25

I upgraded to Ubuntu 17, and my eyes started to get tired very quickly (e.g. in 40 minutes).

It seems to be some problem with the OS, since it didn't happen with the older Ubuntu version, and it doesn't happen with Windows 10.

3
  • 5
  • I installed Ubuntu on a laptop about 2 years ago for somebody else as a Windows replacement and was very unhappy with the quality of text as displayed out-of-the-box, compared to Windows out-of-the-box. I found it unpleasant e.g. to read an online newspaper for extended periods of time. It helped a lot that the machine was dual boot and we could access the Windows partition in order to use the Windows fonts. With some tweaking I found that the text display greatly improved. (The Windows License prohibits copying the fonts, so a Windows partition is a must.) – Peter - Reinstate Monica Nov 6 '17 at 16:01
  • Which was the version of Ubuntu before upgrade ? This may be related to my own sore eyes problem: vince-debian.blogspot.fr/2017/07/…. Bad news is: I haven't been able to fix it so far. – Vincent Fourmond Nov 6 '17 at 21:31
29

One possible cause could be incorrect refresh rate and (or) resolution. This was a generic issue in the time of CRT monitors being, but we could experience similar issues also with the modern monitors. So, find the the monitor's specification and check what are the native values of the refresh rate and the resolution. Or find these values in Windows [1]. Then use xrandr to check the current values (the line marked with asterisk *) and compare them with the default ones.

Unfortunately xrandr has really limited functionalities [2] [3] within Ubuntu 17.10 under Wayland [4]. But it will provide enough information.

enter image description here

If this is the problem the next question should be - how do I change these values within the certain Ubuntu version?

If it is 17.10 on Wayland, you may try to find the native values under the menu Displays, as it is shown on the image from the @pomsky's answer. If they don't exist, you could try to follow this answer, where @Panther describes how to generate and enable custom resolution under Wayland.

Another possible way to solve this problem is to run Ubuntu on Xorg, where xrandr will be more useful. Then you could try to use some solution as these suggested here.

enter image description here

6
  • 3
    This won't work on 17.10 under wayland. Also won't help if a bug in the driver is causing color issues (as is the case with some GPUs on some versions of Ubuntu). – dobey Nov 5 '17 at 18:56
  • 2
    @dobey, I'm agree xrandr isn't very useful under Wayland, but it shall output the current resolution and refresh rate. I cannot see any suggestion for drivers issue, so it could be nice if you convert your comment to an answer. – pa4080 Nov 5 '17 at 20:50
  • 2
    I don't know shall it work, but I found this setting file gsettings get org.gnome.settings-daemon.plugins.xrandr default-configuration-file. – pa4080 Nov 6 '17 at 8:33
  • 1
    xrandr only works under X. – dobey Nov 6 '17 at 12:43
  • @dobey, here is a manual - how that could be done on Wayland: askubuntu.com/a/973582/566421 – pa4080 Nov 7 '17 at 0:01
9

You may try two things.

Reduce display brightness

Click on the rightmost corner of the top bar and use the brightness slider to decrease screen's brightness.

enter image description here

Use "Night Light" feature

Go to Settings > Devices > Displays and click on Night Light. You'll be able to turn on a feature which changes screen's colour temperature to a more soothing one.

enter image description here

1
  • 9
    -1, this doesn't adress the question well. In the OP's system, something apparently changed that is not explainably obvious, so it's unlikely to be either brightness or colour temperature. So your suggestions are at best workarounds for a deeper problem that should be fixed properly. – leftaroundabout Nov 5 '17 at 22:07
5

There is a brilliant piece of software Redshift

for auto screen temperature adjustment. I found it very much relaxing for my eyes, please check this out.

Note: I was not aware of the Ubuntu 17 wayland support, suggest gnome Night light feature instead.

3
  • 2
    Redshift will probably not work in a Wayland session. – pomsky Nov 5 '17 at 12:31
  • 4
    This is built into Ubuntu 17.10 – Tim Nov 6 '17 at 1:36
  • @Tim: It's actually built-into GNOME which is pre-installed on Ubuntu 17.10. ;) – user364819 Nov 6 '17 at 17:04
1

Might help to look if your discrete graphics card is the culprit.

I had this problem earlier that my laptop was heating a lot(with Linux, didn't happen with Windows) and causing me quickly to get tired and end up with burning eyes.

Try to install proper drivers for the graphics card. If it doesn't work, consider disabling the GPU from the BIOS.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.