2

I just installed the most recent version of Skype for Linux, on a 64 bit Asus machine and the result is that the video image is upside down. This does not happen with the Cheese app, where the video result is correct.

I already tried solving the problem following some solutions by installing the libv4l-0:i386 package and launching the app by

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skypeforlinux

and by

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so skypeforlinux

In both cases I get an error:

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

And the app is launched without the preload, with the same obvious result.

Does anybody know how to solve this? It would be much appreciated.

4

To get rid of the Wrong ELF class try this:

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so /usr/bin/skype

or

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

I have to use now "skypeforlinux". I think I used "skype" before too.

If you install:

v4l2ucp

There is a setting: horizontal / vertical flip. This might solve your problem. Good luck.

  • 1
    I tried with both the commands but wasn't able to flip the video. When I run them, the webcam just does not activate, that is the screen is all black, but I don't get any errors in the terminal. While by installing and running the 'v412ucp' package, when I check either vertical or horizontal flip, it does not work for Skype, but it does work when I run the webcam with 'cheese', that's so weird. – Nicco Jan 12 '18 at 15:06
  • For me it works. Having the new Skype version 8 on 64 bit machine which binary has now name skypeforlinux. – jirkamat May 21 '18 at 19:51
  • This works for me too: kubuntu 18.04 x64, skype 8.28, asus K50ID. – zed Aug 19 '18 at 13:06
  • Works for me. I just verified exact path before using it. In my case it's /usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so – MyDogTom Oct 28 '18 at 7:15
  • It works fine with Skype-Version 8.34.0.78 – Eugen Mar 17 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.