I'm having a strange problem on Ubuntu 17.10: when I try to drag and drop something inside Nautilus it simply doesn't work, it doesn't even select the item, it seems like it's ignoring the action... Also, I cannot select things inside nautilus by drawing rectangles with the mouse.

All of these actions work only on the Desktop. Here is a demo:

enter image description here

I'm using the Xorg session with nVidia proprietary drivers. I also noticed that Nautilus seems to hang when I try to copy, paste or cut a file...

EDIT 1: I solved the problem for the slow copy/paste by disabling the clipboard sync plugin of KDEConnect. I also discovered that if I open Nautilus as root, I can drag and drop or select whatever I want...

  • I knew that, but here I'm already using Xorg (also because I have to use nvidia drivers) – Matteo Iervasi Nov 5 '17 at 11:54
  • Ok so now I've solved the copy/paste hanging by disabling clipboard sync on MConnect. But the problem of drag and drop still persist – Matteo Iervasi Nov 11 '17 at 13:26

As Matteo pointed out himself this happens if the Nautilus Flowbox View is enabled. To disable it open a terminal and execute the following:

gsettings set org.gnome.nautilus.preferences use-experimental-views false

Of course you can use the dconf-Editor as well and follow the path above to toggle the setting.

  • 10
    This works in Ubuntu 18 as well. – Ganesh Krishnan Jan 15 '18 at 6:47
  • 1
    Thanks a lot. It's really stupid to invent some 'experimental view' at the cost of losing the drag feature. Finally understand why nautilus suchs so much. – funicorn Jan 17 '18 at 8:30
  • Its false but still doesn't works! – Nikhil Jul 9 '18 at 9:16

It seems I found the culprit: it's the Nautilus flowbox view! I enabled it because I like the automatic streching, but it seems it's disabling the drag and drop and select option. So for now I disabled it

  • 4
    Thanks - this worked for me. Which genius decided to make the decades-old drag-and-drop paradigm obsolete? – Jack Wasey Nov 28 '17 at 18:00
  • how to disable the Nautilus flowbox view? – Nikhil Jun 9 '18 at 8:41
  • Just uncheck the "Experimental view" from the settings, or use the command of user S. Maker – Matteo Iervasi Jun 11 '18 at 8:12
  • 1
    Its false but still doesn't works! – Nikhil Jul 9 '18 at 9:40

You can toggle list view mode, and drag'n'drop will work as expected.

Click the button besides the search button, at the top right corner of the window, next to the window controls:

thumbnails view

Now you can drag'n'drop.

You can also use Ctrl + mouse wheel to enlarge file/folder thumbnails.

  • Thanks, this helped me...but I consider it a bug though...I'll log it – Techedemic Sep 19 '18 at 7:32
  • It works, but it's bug) – Aleksandr Bratashov Jan 28 at 15:03

To fix this, all you have to do is to disable the experimental view again.

Open Nautilus file manager. On the top left, click on Files->Preferences. Clear the “Use the new views” option under Experimental.

Close Files then open again.

enter image description here

  • Btw, this also fixes the shift multiple files or folder selection via keyboard not working problem in nautilus in Ubuntu 18! I don't remember when I enabled it, but since then I have been agitated to use nautilus. – Parth Patel May 11 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.