Here are the first a few items from the output of system-analyze blame and this appears after some kernel updates which I think it's a bug. The systemd-udev-settle uses a lot of time to boot, but I use LVM and cannot disable the service:

1min 29.939s systemd-udev-settle.service
         13.102s NetworkManager-wait-online.service
          4.053s apt-daily.service
          3.121s upower.service
          2.812s apt-daily-upgrade.service
           733ms nmbd.service
           700ms media-I.mount
           647ms media-F.mount
           617ms dictd.service
           616ms irqbalance.service
           610ms ondemand.service
           610ms grub-common.service
           606ms plymouth-start.service
           599ms sysfsutils.service
           597ms apport.service
           592ms speech-dispatcher.service
           473ms dev-mapper-ubuntuvg\x2droot.device
           445ms lvm2-activation-early.service
           385ms lvm2-activation.service
           379ms vboxdrv.service
           274ms lvm2-activation-net.service
           230ms ModemManager.service
           187ms accounts-daemon.service

Apparently, there are something wrong. It boot half way to the maintenance mode and I have to press ctrl+D to continue to finish the booting process. Some error message from the journalctl -xb are (full record can be found here):

-- The start-up result is done.
Nov 04 20:25:48 QC5-ubuntu kernel: Intel(R) Wireless WiFi driver for Linux
Nov 04 20:25:48 QC5-ubuntu kernel: Copyright(c) 2003- 2015 Intel Corporation
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-26.ucode failed with error -2
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-25.ucode failed with error -2
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-24.ucode failed with error -2
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-23.ucode failed with error -2
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-22.ucode failed with error -2
Nov 04 20:25:48 QC5-ubuntu systemd-udevd[588]: failed to execute '/lib/udev/usb-db' 'usb-db /devices/pci0000:00/0000:00:14.0/usb1/1-13': No such file or directory
Nov 04 20:25:48 QC5-ubuntu kernel: iwlwifi 0000:04:00.0: loaded firmware version 21.302800.0 op_mode iwlmvm
Nov 04 20:25:48 QC5-ubuntu kernel: nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 241
Nov 04 20:25:48 QC5-ubuntu mtp-probe[575]: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-10"
Nov 04 20:25:48 QC5-ubuntu mtp-probe[589]: checking bus 1, device 9: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-11"
Nov 04 20:25:48 QC5-ubuntu mtp-probe[575]: bus: 1, device: 7 was not an MTP device
Nov 04 20:25:48 QC5-ubuntu kernel: wmi: Mapper loaded
Nov 04 20:25:48 QC5-ubuntu mtp-probe[589]: bus: 1, device: 9 was not an MTP device
Nov 04 20:25:48 QC5-ubuntu mtp-probe[615]: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-9"
Nov 04 20:25:48 QC5-ubuntu mtp-probe[612]: checking bus 1, device 3: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8"
Nov 04 20:25:48 QC5-ubuntu mtp-probe[615]: bus: 1, device: 5 was not an MTP device
Nov 04 20:25:48 QC5-ubuntu mtp-probe[612]: bus: 1, device: 3 was not an MTP device
Nov 04 20:25:48 QC5-ubuntu kernel: Non-volatile memory driver v1.3
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: ThinkPad BIOS N1EET73W (1.46 ), EC unknown
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: Lenovo ThinkPad P50, model 20ENCTO1WW
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_hwmon thinkpad_hwmon: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: radio switch found; radios are enabled
Nov 04 20:25:48 QC5-ubuntu kernel: random: crng init done
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
Nov 04 20:25:48 QC5-ubuntu kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked

...

- The start-up result is done.
Nov 04 20:25:48 QC5-ubuntu kernel: ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
Nov 04 20:25:48 QC5-ubuntu systemd-udevd[697]: failed to execute '/lib/udev/usb-db' 'usb-db /devices/pci0000:00/0000:00:14.0/usb1/1-13/1-13:1.0': No such file or directory
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: API unit is 2^-32 Joules, 5 fixed counters, 655360 ms ovfl timer
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: hw unit of domain pp0-core 2^-14 Joules
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: hw unit of domain package 2^-14 Joules
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: hw unit of domain dram 2^-14 Joules
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: hw unit of domain pp1-gpu 2^-14 Joules
Nov 04 20:25:48 QC5-ubuntu kernel: RAPL PMU: hw unit of domain psys 2^-14 Joules
Nov 04 20:25:48 QC5-ubuntu kernel: media: Linux media interface: v0.10

...

-- Unit systemd-rfkill.service has begun starting up.
Nov 04 20:25:49 QC5-ubuntu kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
Nov 04 20:25:49 QC5-ubuntu kernel: (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
Nov 04 20:25:49 QC5-ubuntu kernel: thermal thermal_zone3: failed to read out thermal zone (-5)
Nov 04 20:25:49 QC5-ubuntu systemd[1]: Found device PNY_CS1311_480GB_SSD EFI\x20system\x20partition.
-- Subject: Unit dev-disk-by\x2duuid-6226\x2d94B9.device has finished start-up
-- Defined-By: systemd

...

Nov 04 20:25:50 QC5-ubuntu systemd[1]: Failed to start Braille Device Support.
-- Subject: Unit brltty.service has failed

...

-- Subject: Unit dev-mapper-ubuntuvg\x2dhome.device has failed

...

-- Unit dev-mapper-ubuntuvg\x2dhome.device has failed.
-- Unit home.mount has failed.
-- The result is dependency.
Nov 04 20:27:18 QC5-ubuntu systemd[1]: Dependency failed for Local File Systems.
-- Subject: Unit local-fs.target has failed
-- Defined-By: systemd

...

set_control:1461: Cannot write control '2:0:0:Clock Source 10 Validity:0' : Operation not permitted
Nov 04 20:28:48 QC5-ubuntu systemd[1]: tor@default.service: Control process exited, code=exited status=1
Nov 04 20:28:48 QC5-ubuntu systemd[1]: Failed to start Anonymizing overlay network for TCP.
-- Subject: Unit tor@default.service has failed

...

-- Subject: Unit tor@default.service has failed
-- Unit tor@default.service has failed.
Nov 04 20:28:48 QC5-ubuntu systemd[1]: Failed to start LSB: start Samba NetBIOS nameserver (nmbd).
-- Subject: Unit nmbd.service has failed
-- Unit nmbd.service has failed.

...

There are failures about USB ports (I am using a DisplayLink USB 3.0 dock and it seems to be related), Tor-networks (how to disable it at startup?), bluetooth and Samba NetBIOS... The first error might be related to the fact that I was once used to have a tablet connected to my dock while booting, and now I don't have it plugged in anymore. I don't know if there is anything I can reconfigure the boot-up settings and let the machine find the working ports automatically? There are also problems with network manager. The network manager needs a lot of time to boot up, but really? It requires internet to boot up? So, I check which services use it:

$ systemctl show network-online.target | grep -E 'WantedBy|Before'
WantedBy=whoopsie.service samba-ad-dc.service nmbd.service apt-daily.timer smbd.service
Before=whoopsie.service nmbd.service smbd.service rc-local.service apt-daily.timer samba-ad-dc.service snapd.refresh.service

My computer is Thinkpad P50. OS is Ubuntu 16.04.3 with kernel 4.10.0-38. I also have some log outputs on reddit for your reference.

Thanks!

Try masking the systemd-udev-settle service:

sudo systemctl mask systemd-udev-settle.service
  • I have tried that. But it causes more problems than before because I am using LVM file system. But thanks. – Xiaodong Qi Nov 6 '17 at 8:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.