I was previously using Ubuntu 16.04 LTE but upgraded to 17.10. Firefox also upgrade but I lost the HTML5 function on two (and possibly more) websites.

Dailymotion, Twitch and Facebook videos now do not play in HTML5 format despite previously working on Ubuntu 16.04 LTE.

Any help with this is appreciated.

I do not wish to install flash on my Ubuntu machine.

EDIT: I reinstalled my OS again, and upgraded to 17.10 and now I have the same issue. It seems like not all html5 codecs work, despite my hardware supporting all html5 versions.

Unsure if it will correct itself again but it's clearly an issue with Ubuntu 17.10 and Firefox

enter image description here

I installed Ubuntu Restricted Extras (sudo apt-get install ubuntu-restricted-extras). This said that it had fixed the h264 issues but I still get playback issues.

This question should not be closed.

  • Were you using an add-on like "HTML5 Video Everywhere" previously which got disabled during the upgrade? What happens if you disable flash?
    – pomsky
    Nov 4, 2017 at 23:58
  • Move or rename the mozilla folder in ~/.cache/ and ~/.config/, as well rename or move the ~/.mozilla folder and check if it still occurs with a fresh new profile. (if not then you can move your old files back if you so wish). Please tell us your results.
    – Videonauth
    Nov 5, 2017 at 0:00
  • I tried installing "HTML5 Video Everywhere" and it came up with an error message. Previously I was just using Firefox without any extensions and html5 videos for both Dailymotion and Twitch worked. Videonauth, I don't think it due to an addon fault, as I have no installed (re-installing Firefox wasn't what I had planned). Here is some more detail: i.imgur.com/5scvOWx.png
    – Berrik
    Nov 5, 2017 at 0:12
  • Are you logged in to Wayland session? If you log out and switch to the Xorg session, do the videos work again?
    – dobey
    Nov 5, 2017 at 0:16
  • I just logged in with a Xorg session and still get the same issue.
    – Berrik
    Nov 5, 2017 at 0:28

1 Answer 1


Without installing anything, H.264 and MSE & H.264 started working by itself. This means that the videos that previously did not work now work.

No idea how or why this updated, but happy with the results!

Not the answer you're looking for? Browse other questions tagged or ask your own question.