2

I have Windows 10 and Ubuntu 16.04 installed in Dualboot on my laptop in. Before Window's last big fall update, I used to be able to go to the OneDrive folder though "Local Disk" in Ubuntu (after mounting the Windows partition).

I think Microsoft changed how OneDrive works since now I can't access the folder manually, let alone create a working symlink like I want to. It doesn't show up as a folder and I can't open it. It looks like an empty file.

I've already tried disabling "Files on-demand" in Onedrive but that didn't seem to help.

Is there a work-around?

7
  • Maybe try finding and installing a OneDrive plugin for Nautilus. I'm not sure if there is one, but I hope so because there is a DropBox plugin for Nautilus. If there are not any plugins, try finding a way to create a folder as a network link and link it to your OneDrive account. – Bajiru Nov 4 '17 at 15:15
  • Would I have to create a new folder on my Ubuntu partition for that or can I pick the OneDrive folder on my Windows Partition? The reason I'm not inclined to do it that way is because I have a limited amount of space on my harddrive and don't want to have all files double – Joshua Nov 4 '17 at 15:18
  • Try to create a link to your OneDrive account. And, yes, you have to create a folder on your Ubuntu partition. It may copy the files from your cloud to the folder. A link example is this: "net://JoshuaXXXXXXXXXX:@onedrive/" I got the link from the ES File Manager in my smartphone. Try to connect your OneDrive account there. Then tap and hold it, until it is selected. Do not drag it. On the lower right corner you will see "Properties". Tap it. There will be a link similar to the above. Type it into your folder. And that's it! – Bajiru Nov 4 '17 at 15:23
  • The update reverted to the default Fast Startup in Windows. You have to disable it again if you want to access the Windows drive normally from outside (Ubuntu). That said this is something you shouldn't do unless the OneDrive folder is located in a non system partition. – user692175 Nov 4 '17 at 16:42
  • @MichaelBay, I tried that but the problem persists, – Joshua Nov 19 '17 at 14:54
0

i have the same issue and i tried the workaround here: How to read OneDrive NTFS Folder in Ubuntu

just untick Save space and download files as you use them on the Settings tab, it really solved my problem. hope it may also help yours.

1
  • I also had to turn off fast startup in Windows, otherwise I could not access that partition from Ubuntu. – Archisman Panigrahi Feb 20 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.