0

I've just installed Ubuntu on my computer. NOTICE: I have Windows 10 installed on it too!

I tried to switch to 1440x900 resolution but it isn't working. It is not displaying my resolution. And yeah I looked up a bit on forums for solution but it is really confusing. I'm new to Linux systems and I don't know should I do.

I had this problem in Windows 10 too. Solved it by updating drivers and using NVIDIA CONTROL PANEL to set custom resolution.

I know that there are many topics on this but none of them explains what is what.

Also, what do I need to provide? Some outputs or whatsover? I'm using VGA cable.

Thanks.

lspci 

Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)

I'm using Ubuntu 16.04.3 LTS (32 bit).

I'm using 'DVI-I-0' for the connection (although my cable is VGA). So I'm using alternative drivers. This is a image displaying it https://imgur.com/a/6xmYr

Nothing seems to help, i've tried reinstalling drivers, but nothing. Any solution?

  • Please edit your question and specify what version of Ubuntu you are using, and whether you are using Wayland or Xorg (17.10 defaults to Wayland). If you can use DVI instead of VGA for the connection, I would also recommend it. – dobey Nov 5 '17 at 18:37
  • Also please specify in your edit what version of the NVidia graphics driver you're trying to use. – dobey Nov 5 '17 at 18:40
  • I've added the info, mind taking a look? – Luke Nov 5 '17 at 19:18
0

You can use Nvidia Settings, after installing the driver, to set the preferred resolution in Ubuntu, as shown in the pictures below.

Display config

Resolution set

  • I installed NVIDIA X Setting server but I don't have that menu You do. I installed it from Ubuntu Software. EDIT 1: I'm trying to install driver now but I can't find it. I've downloaded a .run application and I can't open it, actually I do with sublime text editor. – Luke Nov 4 '17 at 11:47
  • What menu do you have? You can add a screenshot to the question to show us. – mikewhatever Nov 4 '17 at 11:49
  • This only, imgur.com/a/dz9sP – Luke Nov 4 '17 at 11:52
  • That means the Nvidia driver is not in use. Are there other GPUs? You can check with lspci, might want to add its output to the question. – mikewhatever Nov 4 '17 at 11:58
  • Looks ok, Geforce 9500GT is the only GPU. Have you rebooted after installing the driver? What version of Ubuntu is it? – mikewhatever Nov 4 '17 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.