8

I upgraded from Ubuntu 16.04 to 17.10, via 17.04. After the upgrade, I cannot access the system settings window. When I try to open it through the terminal, this is the error produced.

anomitra@C3PO:/usr/lib/x86_64-linux-gnu$ [INFO 14:56:15.591156] 
Application.vala:153: System Settings version: 2.0
[INFO 14:56:15.591186] Application.vala:155: Kernel version: 4.13.0-
16-generic
[WARNING 14:56:15.635521] PluginManager.vala:115: Unable to scan 
plugins folder: Error opening directory '/usr/lib/x86_64-linux-
gnu/pantheon-online-accounts': No such file or directory
[FATAL 14:56:15.711890] PlugsManager.vala:58: get_plug () not found in 
/usr/lib/x86_64-linux-gnu/switchboard/system/pantheon-
useraccounts/guest-session-toggle
[ERROR 14:56:15.717373] [GLib-GIO] Settings schema 'org.pantheon.dpms' 
is not installed

Any help would be appreciated. Thanks!

7
  • What command did you run?
    – pomsky
    Commented Nov 4, 2017 at 9:33
  • I ran gnome-control-settings
    – Anomitra
    Commented Nov 4, 2017 at 13:28
  • Aren't you talking about ElementaryOS by any chance?
    – user692175
    Commented Nov 4, 2017 at 23:22
  • No, not at all. I'm on Ubuntu. I think 17.10 uses Pantheon in some way.
    – Anomitra
    Commented Nov 5, 2017 at 8:41
  • 1
    In my case, there was a dead old "gnome-control-settings" process running in the background. Killed it and voila! Commented Dec 20, 2018 at 13:25

1 Answer 1

6

You can try to reinstall gnome-control-center from terminal:

sudo apt-get update
sudo apt-get install --reinstall gnome-control-center
4
  • 1
    Doesn't work for me, sadly.
    – Anomitra
    Commented Dec 12, 2017 at 13:13
  • 2
    I get : libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast (gnome-control-center:7059): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed Segmentation fault (core dumped) Commented Apr 3, 2018 at 18:42
  • 1
    Doesn't work for me as well. Anyone solved this yet?
    – afagarap
    Commented Jul 5, 2018 at 1:43
  • See Aram Paronikyan's comment above. Search for an already-running process, e.g. $ ps aux | grep gnome-control-center and then kill the process. After doing that, it may launch properly.
    – sh37211
    Commented Nov 9, 2020 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .