2

Ubuntu 16.0.4.3 Gnome Desktop

I have no text entry or keyboard capabilities in my firefox browser when running in firejail, or regular usrspace.

Running:

firejail firefox --noprofile

results in a firefox browser that will connect successfully to bookmarked links, but wont receive any keyboard input. I then tried running firefox outside firejail in regular usrspace and experienced the same no-kb-working results. I got here by running gnome-www-browser in terminal, which opens a fully functional firefox.

Error messages in terminal:

(firefox:12): IBUS-WARNING **: Events queue growing too big, will start to drop.

(firefox:12): IBUS-WARNING **: Events queue growing too big, will start to drop.

[Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

[Parent 12] WARNING: pipe error (84): Connection reset by peer: file /build/firefox-l1g98U/firefox-56.0+build6/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353 *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping

Dmesg errors:

[pulseaudio] shm.c: shm_open() failed: No such file or directory shm_open() failed: No such file or directory

gnome-session[1768]: console.error: duckduckgo_plus:

gnome-session[1768]: Nothing to show. gnome-session[1768]:

shm_open() failed: No such file or directory gnome-session[1768]:

shm_open() failed: No such file or directory gnome-session[1768]:

console.error: duckduckgo_plus: gnome-session[1768]: Nothing to show. gnome-session[1768]: shm_open() failed: No such file or directory

So my best guess is a shared memory failure messing up the ibus- but nothing in my logs remotely points to its root cause beyond these few reports. Does anyone have any suggestions on how I can track down and isolate this?

1

I had same problem with chromium and skypeforlinux on ubuntu 16.04.1 I have solved this by adding GTK_IM_MODULE=xim in firetools settings like this

GTK_IM_MODULE=xim firejail skypeforlinux
GTK_IM_MODULE=xim firejail chromium-browser

so run from terminal with command line below or go to firetools and press right button on firefox icon and select Edit option to set

GTK_IM_MODULE=xim firejail firefox
  • This works for me. – ozborn Aug 9 '18 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.