1

i am using a fully encrypted LVM disk and running Ubuntu 17.10 Stable. Until recently it was working fine:

grub - decryption password input - boots to OS

Now it's:

grub - busy box "gave up waiting for root device"

I have tried both suggestions on this page:

suggestion 1: "run cryptsetup from within busybox" did not work because cryptsetup is not a recognised command

suggestion 2: "boot from usb, manually decrypt/mount and run update-initramfs", did not show any issues, i was able to go through all steps without issues, but nothing seems to have changed after rebooting. (note: i also confirmed (while in the chroot) that /etc/crypttab exists and it has an entry for sda5_crypt). also tried running update-grub.

Any suggestions? Thanks!

  • It looks like initramfs-tools do not include cryptsetup for some reason. Maybe try changing initramfs system. Follow suggestion 2 but instead of "run update-initramfs" try "apt install dracut" – Andrius Štikonas Nov 5 '17 at 22:54
  • i had to reinstall as i needed to travel with the laptop monday. will try and recreate the problem when i get back from travels though, – Thomas Smart Nov 8 '17 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.