0

I have added a 4TB HDD to my server for /plex and the permissions are user.

I added another 4TB HDD to my server which I partitioned in half, 2TB for /timemachine and 2TB for /general. But the permissions for these two partitions are root and I cannot seem to change the permissions.

I don’t know how I managed to get /plex to have user permissions or whether that was the default ? Does /timemachine and /general have root permissions because they are partitions ?

I would like to access /plex and /timemachine and /general over the network using my Mac Book Pro, but at the moment the Mac can only see /home (and its sub-folders).

How do I configure /plex and /timemachine and /general so that the Mac can see these folders ?

When I intially created /plex I used Disks in Ububtu Desktop to mount the HDD, but this only had root permissions. So I edited fstab so that the drives are mounted at boot without restrictions on the permissions and this worked.

I did the same for /timemachine and /general but for some reason the permissions are root. I have played around with chmod to try and change the permissions but it hasn’t worked.

Below is my fstab:

    # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=447c8859-3065-4c12-94e8-a38b519efda1 /               ext4    noatime,nodiratime,errors=remount-ro 0       1

# /home was on /dev/sda5 during installation
UUID=94a784fa-1a60-4f42-8c73-f576d8e35d30 /home           ext4    noatime,nodiratime 0       2

/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
# swap was on /dev/sda6 during installation
UUID=58725a12-7643-450f-a245-e20628b2769c none            swap    sw              0       0

# remaining space on 1TB HDD
UUID=555678db-af2f-4c32-af8b-b1cc622c8bd8 /storage ext4 defaults 0 2

# sdb for media
UUID=27db9a6d-6c62-4016-841e-7fb5e467f15d /plex ext4 defaults 0 2

# sdc1 for time machine 
UUID=e76948e8-412e-4b08-bd6b-2c3441bcd81c /timemachine ext4 noatime,nodiratime 0 2

# sdc2 for general 
UUID=b9a88247-d9b7-4e19-a96f-70f8668340d7 /general ext4 noatime,nodiratime 0 2

My setup is as follows:

  • Dell PowerEdge T30 Intel Xeon E3-1225v5
  • SATA 0: DVD-RW SATA 1: 1TB HDD
  • SATA 2: WD RED 4TB HDD (/plex)
  • SATA 3: WD RED 4TB HDD (2TB for /timemachine and 2TB for /general)
  • OS: Ubuntu 16.04 LTS (with Ubuntu Desktop)
1

So I edited fstab so that the drives are mounted at boot without restrictions on the permissions and this worked.

This appears to not be the case. Not only are there no such options in your fstab, but these options are not available for ext4 ( they are normally used for non unix filesystems like fat and ntfs ).

You simply need to use sudo chown -R yourname.yourname /general to make them be owned by you.

  • Thanks for the reply psusi. Im not quite sure what you mean when you say "This appears to not be the case. Not only are there no such options in your fstab, but these options are not available for ext4 ( they are normally used for non unix filesystems like fat and ntfs )." I tried sudo chown -R yourname.yourname /general but this hasnt worked, the permissions still show root. – John Nov 3 '17 at 14:42
  • @John, I mean you said you used options in fstab to change the permissions, but you did not. Also of course, you need to use your user name, not literally "yourname". – psusi Nov 4 '17 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.