What happens:
I have (for example) LibreOffice Calc open, with some data columns in it. I highlight the columns I want to chart, then I select INSERT > CHART. The chart child window dialog pops up on top of my data, so I want to move it to the side.

When I grab the top bar and move it, the parent (spreadsheet) window minimizes (I think it actually disappears). Continuing the above example, if I click FINISH on the chart window, I can then see the minimized spreadsheet application, which is the window title bar plus the menu bar just below it.

This seems like really odd behaviour and certainly falls under the category of "not being useful to the user", since the whole idea of moving the child window in the first place was just to be able to better see the spreadsheet!

In other applications, for example the PDF viewer, a slightly different problem occurs. When I try to move the child window (for example the print dialog) the parent does not minimize but instead follows the child window around. This is less surprising than having the parent disappear entirely but equally useless in terms of allowing the user to see the information present in the parent window.

Update 2017/11/06

Pomsky's answer below fixes the problem, but leaves me wondering why the window manager is making the decision that all child windows have modal behaviour (or don't), and not the applications themselves; and further, why modal behaviour prevents moving the child screen around when it obscures useful info on the parent screen. Neither of these seem like good design to me...

up vote 9 down vote accepted

Open Terminal and run

gsettings set org.gnome.shell.overrides attach-modal-dialogs false

This detaches modal dialogues from the parent window and hence should fix your problem.

If this doesn't work see OP's answer or use (GNOME) Tweaks as mentioned below.


The same can be done using (GNOME) Tweaks, there is a toggle button for "Attach Modal Dialogues" in the Windows section. Disable it.
enter image description here

To install Tweaks, run

sudo apt install gnome-tweak-tool
  • Thanks for the idea pomsky! After I had posted this question I discovered a similar suggestion involving the use of dconf to set that value. However it turns out that's not the one that matters; what's important is org.gnome.mutter.attach-modal-dialogs – Monet's Chemist Nov 2 '17 at 21:37
  • 1
    Again, thanks for the pointer to tweak tool, pomsky. This does work just fine. See my comment below about which modal dialog thing needs to be turned on / off. – Monet's Chemist Nov 6 '17 at 19:12
  • 1
    The "Tweaks" solution does work. But the other option "gsetting [...] false" doesn't work: there is a feature in Inkscape to "Live preview" the changes you want to make, and, when checked, the window comes back to being attached, even with the gsettings set to false. – Aurelien Mar 26 at 13:55

Thanks to pomsky's suggestion above, which doesn't quite do the job but led me to the switch I needed.

I used dconf-editor to turn off /org/gnome/mutter/attach-modal-dialogs.

For what its worth the minimizing of the libreoffice spreadsheet appears to have been a side-effect of the parent window being maximized.

Update

Pomsky's suggestion of using the tweak tool is much better than using dconf-editor.

  • What happens if you turn off /org/gnome/mutter/attach-modal-dialogs as you mentioned but turn on /org/gnome/shell/overrides/attach-modal-dialogs? I'm wondering whether both are required or only mutter one is enough. – pomsky Nov 2 '17 at 22:50
  • I just tried this and it seems that "it's mutter that matters" - turning the shell override behaviour back on didn't seem to affect the (desired) behaviour arising from the mutter setting. Is that clear? – Monet's Chemist Nov 6 '17 at 19:14
  • I think you should "un-accept" my answer and accept yours instead. You should always accept the one that helped you most. – pomsky Nov 6 '17 at 19:18
  • 1
    I understand your point, pomsky, but I think in the end your edited suggestion of using the tweak tool (rather than using dconf-editor) is a better solution. – Monet's Chemist Nov 6 '17 at 19:21

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.