My subwo0fer is not working on Ubuntu 11.10. Satellites are all working. It is part of a 5.1 Soundsystem. I've already googled and changed in the /etc/pulse/daemon.conf file these Variables and rebooted:

  • default-sample-channels = 6 (it was "2" before)

  • enable-lfe-remixing = yes (it was "no" before

Could it be possible, that I need a special audio driver? The soundcard is onboard on my ASrock 775i945GZ. If yes where can I get a driver for ubuntu? On Windows XP i use "Realtek high definition audio driver ver:R1.47" (from the ASrock product support site)

EDIT 1 [21.01.2012]

okay, i tried a bit more on my own. I found this website: link

I found out my audio chip is a Realtec alc888

I followed the instructions and added a line in /etc/modprobe.d/alsa-base.conf

I tried out many capabilities but none of them made my subwoffer work... there isn't even a subwoofer regulator in alsamixer!

Now I wrote:

options snd-hda-intel model=6stack-dig

but it is like in pulseaudio: sattelites working, subwoffer silent. I don't know what to do next... Please help!

EDIT 2 [21.01.2012]

okay, now i found out that there is a Linux driver for the high definition audio chipset from Realtek

I installed the latest one with sudo ./install

it took like 2 minutes then it finished.
I rebooted and now there are no sounds at all, there are no devices to configure in the Audio Options!!! And I can't start alsamixer!!!!! :O

Is it my fault? What did I do wrong? Did I forget something?

Please Help!!!

EDIT 3 [21.01.2012]

I wanted to reset also so i typed:

wolfi@wolfi-P4-3:~$ sudo /etc/init.d/alsa-utils reset
[sudo] password for wolfi:

and then it says:

sudo: /etc/init.d/alsa-utils: command not found

Did Realtek destroy alsa??? :O


2 Answers 2


Okay guys I finally found out the solution on myself!

Realtek did destroy alsa indeed, but because ubuntu 11.10's alsa version was too new for Realtek 's driver! So now I'm running Ubuntu 10.4 Lucid Lynx (which GUI I like much more than 11.10's Unity...). I installed the driver after these instructions:

1) get this package

sudo apt-get install build-essential


tar xfvj LinuxPkg_5.16rc25.tar.bz2
cd realtek-linux-audiopack-5.16
tar xfvj alsa-driver-1.0.24-5.16rc25.tar.bz2 

3)Compiling and installing

cd alsa-driver-1.0.24
sudo ./configure --with-cards=hda-intel
sudo make
sudo make install 


sudo reboot

After that I had to change the Hardware Profile to 5.1 Analog Output + Analog Stereo Input and then my Subwoofer finally worked!!!!!!

But then I created a playlist in VLC and after every track my Subwoofer didn't work again!!! Mysterious... But I fixed that too ;) I had to set in /etc/pulse/daemon.conf the line :

enable-lfe-remixing = no


enable-lfe-remixing = yes

Besides that I found out there seems to be a mistake in this file!!!! one line says:

; default-sample-channels

you got to remove the semicolon ( ; ) and enter your number of channels so that it looks like this (for my case a 5.1 system):


After all that trouble I can finally enjoy my 5.1 Sound system on Ubuntu (unfortunately not on the latest version but what should I do ;) )

I hope I can help someone with the same problem because it was hard work for me to find all that stuff out!


I too have this problem, and I can get to the step where I ./configure, but when I try to type in the sudo make command I get this:

jacob@chrono-laptop:~/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24$ sudo make
make[1]: Entering directory `/home/jacob/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/include'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jacob/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/include'
make[1]: Entering directory `/home/jacob/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/acore'
gcc -D__KERNEL__ -DMODULE=1 -I/home/jacob/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/include  -I/lib/modules/3.0.0-16-generic-pae/build/include -I/lib/modules/3.0.0-16-generic-pae/build/include -I/lib/modules/3.0.0-16-generic-pae/build/arch/x86/include -O2 -mpreferred-stack-boundary=2 -march=i686 -Wdeclaration-after-statement -Wno-pointer-sign -D__SMP__ -DCONFIG_SMP -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include -DMODVERSIONS -include /lib/modules/3.0.0-16-generic-pae/build/include/linux/modversions.h  -DKBUILD_BASENAME=memory_wrapper   -c -o memory_wrapper.o memory_wrapper.c
cc1: fatal error: /lib/modules/3.0.0-16-generic-pae/build/include/linux/modversions.h: No such file or directory
compilation terminated.
make[1]: *** [memory_wrapper.o] Error 1
make[1]: Leaving directory `/home/jacob/Downloads/realtek-linux-audiopack-5.16/alsa-driver-1.0.24/acore'
make: *** [compile] Error 1

And I have no clue what to do from here, as I have searched the internet for days!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .