3

This question already has an answer here:

Microsoft just release the new Skype client. I downloaded it from https://www.skype.com/en/get-skype/

The compressed folder has a usr folder with a lot of other files in it. How do I install it ?

sindre@selite:~/Install$ tree usr

usr
├── bin
│   └── skypeforlinux
└── share
    ├── applications
    │   └── skypeforlinux.desktop
    ├── doc
    │   └── skypeforlinux
    │       └── third-party_attributions.html
    ├── icons
    │   └── hicolor
    │       ├── 1024x1024
    │       │   └── apps
    │       │       └── skypeforlinux.png
    │       ├── 16x16
    │       │   └── apps
    │       │       └── skypeforlinux.png
    │       ├── 256x256
    │       │   └── apps
    │       │       └── skypeforlinux.png
    │       ├── 32x32
    │       │   └── apps
    │       │       └── skypeforlinux.png
    │       └── 512x512
    │           └── apps
    │               └── skypeforlinux.png
    ├── pixmaps
    │   └── skypeforlinux.png
    └── skypeforlinux
        ├── blink_image_resources_200_percent.pak
        ├── content_resources_200_percent.pak
        ├── content_shell.pak
        ├── icudtl.dat
        ├── libffmpeg.so
        ├── libnode.so
        ├── LICENSES.chromium.html
        ├── locales
        │   ├── am.pak
        │   ├── ar.pak
        │   ├── bg.pak
        │   ├── bn.pak
        │   ├── ca.pak
        │   ├── cs.pak
        │   ├── da.pak
        │   ├── de.pak
        │   ├── el.pak
        │   ├── en-GB.pak
        │   ├── en-US.pak
        │   ├── es-419.pak
        │   ├── es.pak
        │   ├── et.pak
        │   ├── fake-bidi.pak
        │   ├── fa.pak
        │   ├── fil.pak
        │   ├── fi.pak
        │   ├── fr.pak
        │   ├── gu.pak
        │   ├── he.pak
        │   ├── hi.pak
        │   ├── hr.pak
        │   ├── hu.pak
        │   ├── id.pak
        │   ├── it.pak
        │   ├── ja.pak
        │   ├── kn.pak
        │   ├── ko.pak
        │   ├── lt.pak
        │   ├── lv.pak
        │   ├── ml.pak
        │   ├── mr.pak
        │   ├── ms.pak
        │   ├── nb.pak
        │   ├── nl.pak
        │   ├── pl.pak
        │   ├── pt-BR.pak
        │   ├── pt-PT.pak
        │   ├── ro.pak
        │   ├── ru.pak
        │   ├── sk.pak
        │   ├── sl.pak
        │   ├── sr.pak
        │   ├── sv.pak
        │   ├── sw.pak
        │   ├── ta.pak
        │   ├── te.pak
        │   ├── th.pak
        │   ├── tr.pak
        │   ├── uk.pak
        │   ├── vi.pak
        │   ├── zh-CN.pak
        │   └── zh-TW.pak
        ├── natives_blob.bin
        ├── pdf_viewer_resources.pak
        ├── resources
        │   ├── app.asar
        │   ├── app.asar.unpacked
        │   │   └── node_modules
        │   │       ├── keyboard-layout
        │   │       │   └── build
        │   │       │       └── Release
        │   │       │           └── keyboard-layout-manager.node
        │   │       ├── keytar
        │   │       │   └── build
        │   │       │       └── Release
        │   │       │           └── keytar.node
        │   │       ├── @paulcbetts
        │   │       │   ├── cld
        │   │       │   │   └── build
        │   │       │   │       └── Release
        │   │       │   │           └── cld.node
        │   │       │   └── spellchecker
        │   │       │       └── build
        │   │       │           └── Release
        │   │       │               └── spellchecker.node
        │   │       ├── slimcore
        │   │       │   └── bin
        │   │       │       ├── sharing-indicator.node
        │   │       │       └── slimcore.node
        │   │       └── sqlite3
        │   │           └── lib
        │   │               └── binding
        │   │                   └── node_sqlite3.node
        │   ├── default_app.asar
        │   └── electron.asar
        ├── skypeforlinux
        ├── snapshot_blob.bin
        ├── ui_resources_200_percent.pak
        ├── version
        └── views_resources_200_percent.pak

41 directories, 87 files

(Question is for new Skype for Ubuntu 17.10. Old answers does not help.)

marked as duplicate by pomsky, pa4080, dobey, Videonauth, edwinksl Nov 2 '17 at 15:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 4
    On Ubuntu, you would download the file skypeforlinux-64.deb and install that with sudo dpkg -i skypeforlinux-64.deb. Of just double-click the file in the Downloads folder. – Jos Nov 2 '17 at 14:15
  • 2
    You need to make sure that you're downloading the .deb files [Debian / Ubuntu] rather than the .rpm [Red Hat]. It "should" download something, 63megs of .deb file. Click / double clicking "should" open the Ubuntu Software, after which yo should be able to "auto" install. – Piloti Nov 2 '17 at 14:16
  • Have you tried double clicking the .deb file? – lapisdecor Nov 2 '17 at 14:17
  • I do not think this is a duplicate, since the main answers of the other question are no longer valid. Skype has changed his client since the summer 2017 – Frédéric Grosshans Nov 21 '17 at 14:57
  • 2
    To be more precise: Skype rejects connections from the old client since the summer 2017. So the pominent answers in the “duplicate” question are no longer useful, even on old versions of Ubuntu – Frédéric Grosshans Nov 22 '17 at 11:28
10

Updated 1-2-2018

Canonical has announced that Skype is now available as a Snap, so it can be installed direct from the Ubuntu-Software or by using snap:

snap install --classic skype

or you can use the link: https://snapcraft.io/skype

Old Method

If you prefer to install it with Debian package manager use the old method:

Refer to the https://www.skype.com/en/get-skype/ page. Then choose the option

get Skype for linux Deb

then a .deb file will be downloaded. Open the terminal, refer to the folder where the .deb was downloaded (Or right mouse click in the folder and choose open in terminal). Then run:

sudo dpkg -i skypeforlinux-64.deb

if it showes any problem run: sudo apt install -f

when it finishes delete the skypeforlinux-64.deb file.

  • 2
    This site has a way to add the last (2017) client of Skype so that it is upgraded when you perform an apt upgrade: websiteforstudents.com/install-upgrade-skype-ubuntu-17-04-17-10 – Frédéric Grosshans Nov 21 '17 at 15:01
  • @FrédéricGrosshans This worked very smoothely. – SeMa Dec 19 '17 at 14:26
  • That websiteforstudents.com looks nice, but when I click on it, it hijacks Firefox to try to force me to do a "manual update". Nasty. The Skype instructions are good, though, so I've saved the page in a gist if anyone wants to save the aggro from the original site (also linked in the gist). – Dɑvïd Jan 12 '18 at 10:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.