1

I upgraded to Artful yesterday and ever since ever time I run 'apt update' I get:

Building dependency tree
Reading state information... Done 35 packages can be upgraded. Run 'apt list --upgradable' to see them.

If I run 'apt upgrade' it does nothing but if I run 'apt list --upgradable' I get a list of packages from a statistical language called 'R'

~$ apt list --upgradable

Listing... Done

r-cran-assertthat/artful,artful 0.1-1build1 all [upgradable from: 0.1-1]

r-cran-bitops/artful 1.0-6-1build1 amd64 [upgradable from: 1.0-6-1]

and 33 more lines.

Any ideas anyone?

Edit: I looked at the answer to Cannot install R on ubuntu 17.10 and tried a 'sudo aptitude full-upgrade' here are the results:

    $ sudo aptitude full-upgrade
The following NEW packages will be installed:
  libjs-jquery-metadata{a} libjs-jquery-tablesorter{a} 
  libjs-twitter-bootstrap{a} 
The following packages will be upgraded:
  r-cran-assertthat{b} r-cran-bitops{b} r-cran-codetools{b} 
  r-cran-colorspace{b} r-cran-crayon{b} r-cran-curl{b} r-cran-dichromat{b} 
  r-cran-digest{b} r-cran-evaluate{b} r-cran-ggplot2{b} r-cran-gtable{b} 
  r-cran-labeling{b} r-cran-lazyeval{b} r-cran-learnbayes{b} 
  r-cran-magrittr{b} r-cran-munsell{b} r-cran-openssl{b} r-cran-pbdzmq{b} 
  r-cran-pkgkitten{b} r-cran-plyr{b} r-cran-r6{b} r-cran-rcolorbrewer{b} 
  r-cran-rcpp{b} r-cran-rcurl{b} r-cran-repr{b} r-cran-reshape2{b} 
  r-cran-rgtk2{b} r-cran-scales{b} r-cran-spatial{b} r-cran-stringi{b} 
  r-cran-stringr{b} r-cran-tibble{b} r-cran-uuid{b} r-cran-xml{b} 
  r-cran-xml2{b} 
35 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.8 MB of archives. After unpacking 2,413 kB will be used.
The following packages have unmet dependencies:
 r-cran-xml2 : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-colorspace : Depends: r-api-3.4 which is a virtual package, provided by:
                              - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-uuid : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-labeling : Depends: r-api-3.4 which is a virtual package, provided by:
                            - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-crayon : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-rcolorbrewer : Depends: r-api-3.4 which is a virtual package, provided by:
                                - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-bitops : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-r6 : Depends: r-api-3.4 which is a virtual package, provided by:
                      - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-curl : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-reshape2 : Depends: r-api-3.4 which is a virtual package, provided by:
                            - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-gtable : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-plyr : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-xml : Depends: r-api-3.4 which is a virtual package, provided by:
                       - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-magrittr : Depends: r-api-3.4 which is a virtual package, provided by:
                            - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-rgtk2 : Depends: r-api-3.4 which is a virtual package, provided by:
                         - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-scales : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-pbdzmq : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-spatial : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-rcpp : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-assertthat : Depends: r-api-3.4 which is a virtual package, provided by:
                              - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-munsell : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-codetools : Depends: r-api-3.4 which is a virtual package, provided by:
                             - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-repr : Depends: r-api-3.4 which is a virtual package, provided by:
                        - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-digest : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-rcurl : Depends: r-api-3.4 which is a virtual package, provided by:
                         - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-stringi : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-stringr : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-evaluate : Depends: r-api-3.4 which is a virtual package, provided by:
                            - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-learnbayes : Depends: r-api-3.4 which is a virtual package, provided by:
                              - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-tibble : Depends: r-api-3.4 which is a virtual package, provided by:
                          - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-openssl : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-dichromat : Depends: r-api-3.4 which is a virtual package, provided by:
                             - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-lazyeval : Depends: r-api-3.4 which is a virtual package, provided by:
                            - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-ggplot2 : Depends: r-api-3.4 which is a virtual package, provided by:
                           - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

 r-cran-pkgkitten : Depends: r-api-3.4 which is a virtual package, provided by:
                             - r-base-core (3.4.2-1ubuntu1), but 3.4.2-2zesty is installed

The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      r-cran-assertthat [0.1-1 (now)]                    
2)      r-cran-bitops [1.0-6-1 (now)]                      
3)      r-cran-codetools [0.2-15-1 (now)]                  
4)      r-cran-colorspace [1.3-2-1 (now)]                  
5)      r-cran-crayon [1.3.2-1 (now)]                      
6)      r-cran-curl [2.3-1ubuntu2 (now)]                   
7)      r-cran-dichromat [2.0.0-3 (now)]                   
8)      r-cran-digest [0.6.12-1 (now)]                     
9)      r-cran-evaluate [0.10-1 (now)]                     
10)     r-cran-ggplot2 [2.2.1-2 (now)]                     
11)     r-cran-gtable [0.2.0-1 (now)]                      
12)     r-cran-labeling [0.3-1 (now)]                      
13)     r-cran-lazyeval [0.2.0-1 (now)]                    
14)     r-cran-learnbayes [2.15-3 (now)]                   
15)     r-cran-magrittr [1.5-3build1 (now)]                
16)     r-cran-munsell [0.4.3-1 (now)]                     
17)     r-cran-openssl [0.9.6-1 (now)]                     
18)     r-cran-pbdzmq [0.2.5+dfsg-1 (now)]                 
19)     r-cran-pkgkitten [0.1.4-1 (now)]                   
20)     r-cran-plyr [1.8.4-1 (now)]                        
21)     r-cran-r6 [2.2.0-2 (now)]                          
22)     r-cran-rcolorbrewer [1.1-2-1 (now)]                
23)     r-cran-rcpp [0.12.9-1 (now)]                       
24)     r-cran-rcurl [1.95-4.8-2 (now)]                    
25)     r-cran-repr [0.10-1 (now)]                         
26)     r-cran-reshape2 [1.4.2-1 (now)]                    
27)     r-cran-rgtk2 [2.20.31-2 (now)]                     
28)     r-cran-scales [0.4.1-1 (now)]                      
29)     r-cran-spatial [7.3-11-1zesty0 (now)]              
30)     r-cran-stringi [1.1.2-1 (now)]                     
31)     r-cran-stringr [1.1.0-1 (now)]                     
32)     r-cran-tibble [1.2-1 (now)]                        
33)     r-cran-uuid [0.1.2-8 (now)]                        
34)     r-cran-xml [3.98-1.5-1 (now)]                      
35)     r-cran-xml2 [1.1.0-1ubuntu1 (now)]                 



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
  • How had you installed R in 17.04? – Charles Green Nov 2 '17 at 17:25
  • apt install r-cran-recommended – Paula Thomas Nov 2 '17 at 23:56
  • There does not seem to be a package by that name in the Ubuntu repositories. Is it a .deb or PPA that you got from another source? – Charles Green Nov 3 '17 at 0:01
  • Sorry got the name slightly wrong, it is "r-commended" details: Sorting... Done Full Text Search... Done r-recommended/now 3.4.2-2zesty all [installed,local] GNU R collection of recommended packages [metapackage] – Paula Thomas Nov 3 '17 at 0:20
  • K - so part of the problem is that the Ubuntu archives for Zest only supply version 3.3.2 for rbase/zesty, yet you have version 3.4.2 for Zesty. Is there a line in your sources which looks something like deb https://<my.favorite.cran.mirror>/bin/linux/ubuntu zesty/ where the cran mirror might be defined as somewhere in this list – Charles Green Nov 3 '17 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.