15

I upgraded from 17.04 to 17.10 on my XPS13 9360 and have, as others, tons of issues. This one now is that the process

/usr/bin/gnome-shell

has a way to high CPU usage of constantly between 20 and 30%:

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                                                                     
2026 xxxxxx   20   0 4264020 703284 315308 S  29,6  4,3   9:32.37 gnome-shell                                                                                                 

The used version is

$ gnome-shell --version
GNOME Shell 3.26.1

This happens directly after booting the system with nothing open except a terminal running htop (beside some startup apps such as Dropbox) but clearly no heavy graphics programs. I don't know where to start, here are some information about my graphics card

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)

$ glxinfo | grep -i render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

Please let me know what else I should post in order to trace this issues -- many thanks!

  • If your video card is relatively under powered gnome-shell uses llvm-pipe to use your cpu for 3d effects. You can try an alternate DE or google search to see if there is a solution for your graphics card or work around (you did not tell us much about your system or want is using your cpu). – Panther Nov 2 '17 at 15:06
  • Please post the output of glxinfo | grep -i render – Charles Green Nov 2 '17 at 15:52
  • 1
    @bb94, for me it turned out that the gnome-shell process went down to below 10% when turning off the system monitor extensions.gnome.org/extension/120/system-monitor. Writing this as an answer now. – Christian Nov 7 '17 at 9:28
  • 2
    @ChristianStump That would be great if I didn't already have it off. – bb94 Nov 7 '17 at 17:09
  • 1
    @bb94, I'm having the same issue with 20-30% gnome-shell CPU usage (with only terminal open), and I don't have any gnome extensions running. – user36196 Nov 11 '17 at 0:17
12

It turned out that the gnome-shell process went down to below 10% when turning off the system monitor extension https://extensions.gnome.org/extension/120/system-monitor/.

It also stays below 10% when increasing the refresh time to 1sec, while it went up again as soon as I moved it below 1sec.

1

I have come across the same gnome-shell cpu hog issue and it was kmailservice5 that fires up the cpu when you don't have Thunderbird. Whenever I click on a mailto link, the cpu goes crazy and so does gnome-shell and kmailservice5 does nothing. It's a reported KDE bug and has been fixed since but for other Ubuntu LTS like 16.10, the fix is to uninstall kmailservice5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.