4

Ubuntu 17.10, clean install, default video player (totem?)

Having a problem with the Videos application. When I try to play a video, I get audio, but no video (just a black window). The video appears to be playing (I can shift from point to point in the video with the slider at the bottom - it shows a different time point in the video, and continues to "play" from there - but never any actual image, just the audio). This happens with any video I attempt to play. Note that the thumbnailer app is correctly reading the video, as it generates appropriate thumbnails for each one.

It doesn't seem to be a hardware problem, as I have multiple versions of Ubuntu installed (on different partitions), and the same video files play without problem on older versions (16.04, 17.04).

I have installed the ubuntu-restricted-extras package to get the appropriate codecs and such - it installed without a problem.

When running it from the terminal, it produces the following error: (totem:2345): GLib-CRITICAL **: g_key_file_load_from_file: assertion 'file != NULL' failed

And the syslog gives:

Nov 15 17:10:44 -HP-Compaq-8200-Elite-CMT-PC totem[10043]: Native Windows taller than 65535 pixels are not supported Nov 15 17:10:45 -HP-Compaq-8200-Elite-CMT-PC totem[10043]: g_key_file_load_from_file: assertion 'file != NULL' failed Nov 15 17:10:52 -HP-Compaq-8200-Elite-CMT-PC dbus[613]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' Nov 15 17:10:52 -HP-Compaq-8200-Elite-CMT-PC systemd[1]: Starting Hostname Service... Nov 15 17:10:52 -HP-Compaq-8200-Elite-CMT-PC dbus[613]: [system] Successfully activated service 'org.freedesktop.hostname1' Nov 15 17:10:52 -HP-Compaq-8200-Elite-CMT-PC systemd[1]: Started Hostname Service. Nov 15 17:10:58 -HP-Compaq-8200-Elite-CMT-PC totem[10043]: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)3-HP-Compaq-8200-Elite-CMT-PC totem[10170]: Native Windows taller than 65535 pixels are not supported Nov 15 17:14:58 HP-Compaq-8200-Elite-CMT-PC totem[10170]: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale) Nov 15 17:14:58 -HP-Compaq-8200-Elite-CMT-PC totem[10170]: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale) Nov 15 17:15:32 -HP-Compaq-8200-Elite-CMT-PC gnome-software[2504]: running search with refine-flags=require-license,require-description,require-rating,require-version,require-history,require-setup-action,require-origin,require-provenance,require-review-ratings,require-icon,require-permissions,require-origin-hostname with failure-flags=use-events with timeout=10 with max-results=50 with search=totem on plugin=snap on apps system/snap/Snap Store/desktop/minidlna-escoand/*,system/package/ubuntu-artful-main/desktop/org.gnome.Totem.desktop/* took 713ms Nov 15 17:15:40 -HP-Compaq-8200-Elite-CMT-PC gnome-software[2504]: running refine with refine-flags=require-license,require-url,require-size,require-version,require-history,require-setup-action,require-origin,require-menu-path,require-addons,require-provenance,require-icon,require-permissions,require-origin-hostname,require-runtime,require-screenshots with failure-flags=use-events with timeout=60 on apps system/package/ubuntu-artful-main/desktop/org.gnome.Totem.desktop/* Nov 15 17:15:41 -HP-Compaq-8200-Elite-CMT-PC gnome-software[2504]: running refine with refine-flags=require-rating,require-reviews,require-review-ratings with failure-flags=use-events with timeout=60 on apps system/package/ubuntu-artful-main/desktop/org.gnome.Totem.desktop/* took 1022ms

Any suggestions?

[edit 11/17] Got an update to gstreamer today while doing routine updates, and now some files show video while others don't. Here is the stream info for one that does not show video (stream info retrieved using ffprobe):

Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 640x360 [SAR 1:1 DAR 16:9], 493 kb/s, 29.97 fps, 29.97 tbr, 11988 tbn, 59.94 tbc (default)
Metadata:
  handler_name    : VideoHandler
Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 48 kb/s (default)
Metadata:
  handler_name    : SoundHandler

[edit 1/9/18] Output when attempting to launch video from command window:

tracy@tracy-hp:/mnt/7BC9480105AD511D/Test$ totem Testing.mp4

(totem:8700): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)

(totem:8700): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)
tracy@tracy-hp:/mnt/7BC9480105AD511D/Test$ 

Still no video output. It is worth noting (in regard to other comments posted) that I do have gstreamer1.0-plugins-ugly installed (for h264 support). Here are the gstreamer packages installed:

gstreamer1.0-alsa/artful,now 1.12.3-1 amd64 [installed]
gstreamer1.0-clutter-3.0/artful,now 3.0.24-1 amd64 [installed]
gstreamer1.0-fluendo-mp3/artful,now 0.10.32.debian-1 amd64 [installed,automatic]
gstreamer1.0-libav/artful,now 1.12.2-1 amd64 [installed]
gstreamer1.0-nice/artful,now 0.1.13-2 amd64 [installed,automatic]
gstreamer1.0-packagekit/artful,now 1.1.7-1 amd64 [installed]
gstreamer1.0-plugins-bad/artful,now 1.12.3-1ubuntu1 amd64 [installed]
gstreamer1.0-plugins-base/artful,now 1.12.3-1 amd64 [installed]
gstreamer1.0-plugins-base-apps/artful,now 1.12.3-1 amd64 [installed]
gstreamer1.0-plugins-good/artful,now 1.12.3-1ubuntu1 amd64 [installed]
gstreamer1.0-plugins-ugly/artful,now 1.12.3-1 amd64 [installed,automatic]
gstreamer1.0-pulseaudio/artful,now 1.12.3-1ubuntu1 amd64 [installed]
gstreamer1.0-tools/artful,now 1.12.3-1 amd64 [installed]
gstreamer1.0-vaapi/artful,now 1.12.3-1ubuntu1 amd64 [installed,automatic]
gstreamer1.0-vaapi-doc/artful,artful,now 1.12.3-1ubuntu1 all [installed]
gstreamer1.0-x/artful,now 1.12.3-1 amd64 [installed]

Additional edit 1/9/18: Thanks to Roberto Lineros. Removing gstreamer1.0-vaapi appears to have resolve this for me. Videos are now playing, including h264 videos (mp4 formats).

  • I currently have the same issue as well. – Max Nov 16 '17 at 1:14
  • Updates from this morning to gstreamer have fixed some of the problems. Playing some files now provides video, but others do not. Added info from ffprobe on one of the files that does not show video – Tracy Nov 17 '17 at 15:21
  • although VLC does work but it has a lacking interface with more features – Max Nov 18 '17 at 6:06
  • What is the output when you launch the video mentioned in your 11/17 edit from the command line? I.E. totem videoname – Elder Geek Jan 8 '18 at 16:32
  • No useful information is returned in the command window - edit added to original post showing output. – Tracy Jan 9 '18 at 16:23
2

I am using Ubuntu 17.10 and I confirm the issue.

The problem can be solved by removing gstreamer1.0-vaapi

In my case, I used

sudo apt purge gstreamer1.0-vaapi

after that, totem should display video as usual.

The solution I found here: https://bbs.archlinux.org/viewtopic.php?id=220186

  • 1
    Can you explain how removing this package will add functionality? – Elder Geek Jan 8 '18 at 15:36
  • Perfect! Removing gstreamer1.0-vaapi causes video to appear when playing files that previously were blank screen. I will test in more detail as the day goes on, but this appears to have resolved my problem. – Tracy Jan 9 '18 at 16:41
  • @ElderGeek I am not really sure the role of that package. I just found that removing it allows the video to be seen again. Sorry – Roberto A. Lineros Jan 10 '18 at 17:03
  • To the best of my knowledge, Gstreamer-vaapi is a collection of GStreamer plugins and helper libraries that allow hardware accelerated video decoding, encoding and processing through VA-API. . This package contains GStreamer plugins for VA-API support: I believe that they are development files for libraries from the "bad" set, not the ugly set which contains the h264 codec. Are you sure you didn't install gstreamer 1.0-plugins-ugly as well in your quest to solve this problem? – Elder Geek Jan 11 '18 at 14:58
0

If it's not necessary to use the video player provided by Ubuntu itself. You have better use VLC player, which is great.

sudo apt update
sudo apt install vlc
  • OP didn't ask for an alternative. – MANI Nov 2 '17 at 5:44
  • Thanks for the pointer to VLC. But I don't want to load up my system with a large variety of apps, when the built in apps should serve. Plus my concern is that the new app will behave the same as the built in app, thus resulting in no net gain. – Tracy Nov 3 '17 at 12:42
  • @MANI Alternatives are fine. Please review askubuntu.com/help/how-to-answer – Elder Geek Jan 8 '18 at 16:27
0

It sounds like you are missing gstreamer1.0-plugins-ugly which contains the h264 codec for 17.10. It's available in the universe repository. if not, you appear to be affected by this bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.