0

I wanted to install the Japanese language on my ubuntu 16.04, but following some tutorials, I realized that it was not present in the language-support panel, in install/remove languages. In almost every discussion I have seen on this topic, people could choose a wide variety of languages, but I can only choose between French or English. The only person with the same problem magically solved it with a apt-get update, but it didn't work for me. Here is a picture.

Install/Remove language menu

What can I do ?

My ultimate goal is to be able to type japanese like in windows (typing in romanji, which converts into kana and kanjis), and I found tutorials but it requires the support of the japanese language.

Thanks !

  • sudo apt update by itself solves nothing because it does nothing else than checking the repositories for newer versions of installed packages. Follow it by sudo apt full-upgrade and it may work because the second command is what downloads and installs the updates you need. – user692175 Nov 2 '17 at 2:00
  • If what @MichaelBay suggested does not help, can you please start Language Support from terminal with the command gnome-language-selector. Then click the Install / Remove Languages... button, and let us know any messages which show up in terminal. Copy the output and paste it into your question (by editing it). – Gunnar Hjalmarsson Nov 2 '17 at 2:06
  • I did the full-upgrade, and it didn't change anything. No message appears in terminal when I click the Install/Remove Languages button. – Pietrovosky Nov 2 '17 at 3:01
  • Do you have a working Internet connection? – Gunnar Hjalmarsson Nov 2 '17 at 4:22
  • Yes I do, it's perfectly working. – Pietrovosky Nov 2 '17 at 4:47
0

I have no idea why the not installed languages don't show up in that list.

But these are some steps to let you type Japanese anyway:

  • Install Fcitx

    sudo apt install fcitx
    
  • Install a Japanase input method engine

    sudo apt install fcitx-mozc
    
  • Make Fcitx the input method framework

    im-config -n fcitx
    
  • Reboot

  • Go to System Settings -> Text Entry and add Mozc to the input sources

  • Sorry for the late response. I think I may have a problem with my packages because i get an error message, saying that there is no version that can be installed. Mozc cannot be found either... – Pietrovosky Nov 6 '17 at 0:18
  • @Pietrovosky: If you need help to sort out that package issue, I'd suggest that you ask a new question, where you provide as much details as you can about the problem. – Gunnar Hjalmarsson Nov 6 '17 at 0:37
  • OK, I tried few things first, and magically... it worked, even though I don't know why. I have downloaded the fcitx and fticx-mozc packages from a website and tried to install them. I got an error message concernings missing librairies, but they were recognized anyway, but still did not work. My package manager (I think) said that the packages were corrupted, and I needed to do apt-get -f install. I did that, which removed the two packages. Next thing, I launch the language support window, it proposes an update, and magically all languages appear now. Thanks to everyone for their help ! – Pietrovosky Nov 6 '17 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.