After upgrading to 17.10, I had no issue neither with GNOME (which I use the most) on Xorg nor Unity. But once, while on a GNOME session, I wasn't able to open some applications (including Settings) and since then I'm not able to log in to the GNOME session.

What happens :

  • When trying to log in to GNOME (either vanilla GNOME or 'Ubuntu' GNOME, and either on Xorg or Wayland - when it is listed), I enter my password, then I got a black screen for a few seconds and then I'm back on the log in screen.
  • When logging in Unity session (which works more or less), I got this error :

    Could not apply the stored configuration for monitors

    required virtual size does not fit available size: requested=(1, 1), minimum=(320, 200), maximum=(8192, 8192)

  • I later noticed that there is many more lines displayed on boot, including several time this kind of errors Error: Method parse/execution failed ..., ACPI Error: [_OSI] Namespace lookup failure, as well as this line once Couldn't get size : 0x800000000000000e

What I tried :

  • I read this issue (Ubuntu 17.10 freezes after logging on wayland), but since I can't log on GNOME at all, I wasn't able to disable my extensions to see if it resolved the issue. Removing and reinstalling NVIDIA packages didn't help (I've got a GeForce GT 840M, in addition to Intel default graphics).
  • I changed the driver used for the graphic card. I tried both NVIDIA proprietary driver (version 384) and 'X.Org X server', and all that changed was the 'minimum' and 'maximum' size on the error message.
  • Since I'm not using any second monitor (I'm on a laptop, so I only have the built-in display), I checked that Ubuntu wasn't trying to connect to another - non existing - display and I see no other display in the System Settings. The settings also tell me that the resolution is the default one (1366x768), so I guess it recognizes correctly the built-in display. I might (probably) be wrong on this last point.
  • I, of course, rebooted my system after every try to be sure it had not solved my issue.
  • Does it work if you boot 17.10 from a live USB ? Failed upgrades can be difficult and with all the changes ..... – Panther Nov 1 '17 at 22:56
  • I'll try that (again, I already did it for a completely different issue), but I don't think the upgrade is the cause: it worked well for almost 2 weeks after the upgrade... – N. Cornet Nov 1 '17 at 23:17
  • open source or nvidia driver ? – Panther Nov 1 '17 at 23:19
  • 1
    It makes it more likely you have a corrupt config. Try deleting all unity and gnome configuration files and log out and back in. – Panther Nov 2 '17 at 0:26
  • 1
    Try this - askubuntu.com/questions/56313/… – Panther Nov 2 '17 at 0:42

I solved by issuing:

dpkg-reconfigure lightdm && service lightdm restart

Maybe the same can solve for gdm

| improve this answer | |

I finally did as @Panther suggested : I reset GNOME as explained here, yet I still had the issue in Unity. As I used mostly GNOME I didn't bothered about Unity, but I eventually made a fresh install of 17.10 for several other reasons.

Since the issue appeared some time ago I not sure about this, but I seem to remember that it was a Shell Extension that caused the issue. I think it might be ISS Above, because I installed it the day I got the issue and I didn't install it back after the reset, but not sure (for anyone who would run in the same issue).

| improve this answer | |

I was having a similar issue after upgrading from 16.10 to 17.10: the gnome session worked, but the unity one kept displaying the "required virtual size does not fit [...]" message and my double monitor setup was not being properly handled (monitors were swapped).

I've then had a look at the ~/.config/monitors.xml file and noticed that it had changed format! At its top was now a <monitors version="2"> string, whilst the previous one had a <monitors version="1"> string, and the rest of the file showed a completely different layout and tags.

I thus concluded that the message "required virtual size does not fit [...]" was being displayed by unity-settings-daemon which failed to parse the content of the new monitors.xml file.

Adding to that was the fact that the the display panel in the gnome-control-center was not working during the Unity session, due to error:

GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.DisplayConfig was not provided by any .service files

I therefore installed unity-control-center, ran it, and sure enough the Display panel was working and the correct (previous version) monitor.xml was being written.

After a reboot, everything worked as expected.


The problem seems to be related to a mismatch between the expected monitor.xml and the real one. Unity and Gnome shell write and parse different and incompatible versions of that file, which makes it impossible to seamlessy switch between those two session types.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.