2

I’ve been trying to get VLC media player to play DVDs with no success. I believe I’ve installed all the needed files. I used “How To Play DVD In Ubuntu 14.04 And 16.04” from Itsfoss.com, and installed libdvdcss2, libdvdread4, and libdvdnav4. It still wouldn’t work, so I tried to change the region code on the DVD drive, but wasn’t able to.

I ran sudo apt-get install regionset. Then I ran sudo regionset after which the terminal results read:

regionset version 0.1 -- reads/sets region code on DVD drives
Current Region Code settings:
RPC Phase: II
type: NONE
vendor resets available: 4
user controlled changes resets available: 5
drive plays discs from region(s):, mask=0xFF

Would you like to change the region setting of your drive? [y/n]:y
Enter the new region number for your drive [1..8]:0
New mask: 0x00, correct? [y/n]:y
ERROR: Region code could not be set!

I don't understand the existing code on the drive being "0xFF," not just 0. When I try to play a DVD, VLC shows the title, then shuts down a few seconds later.

VLC played DVDs fine with this same DVD drive when I was using Ubuntu 14.04, but I had to scrub the hard drive and start from scratch with 16.04. Now I can't get VLC to work.

Thank you much for your help.

4
  • help.ubuntu.com/community/RestrictedFormats/PlayingDVDs . Also regionset requires setting an actual region (1...8). Zero is not a region code. Usually there's no need to change this if the DVDs played with the same drive before.
    – user692175
    Nov 1, 2017 at 22:15
  • OK. I thought 0 was North America. At any rate, it's fixed itself. I think the installer was hung up on a previous install, and preventing me from updating the distro. While I was installing the needed software to play the DVDs, terminal said there were some no longer needed files, so I removed them. After I did that, I was able to update, and after I updated, VLC played DVDs just fine. I haven't a clue why. Thanks for your help.
    – Jim T
    Nov 2, 2017 at 22:14
  • Also, can someone either tell me, or give me a link, for how to format terminal commands and output in a post. I searched, but come up with nothing.
    – Jim T
    Nov 2, 2017 at 22:16
  • Use {} and paste the code inside. The "backtick" - ` - can be used as well and, in comments, it's actually the only way to indicate code/commands. Like this: lsusb.
    – user692175
    Nov 2, 2017 at 22:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.