0

For some reason I cannot stop the GRUB menu from appearing every boot on my Ubuntu 14.04.05 installation.

I have ensured that my /etc/default/grub file has GRUB_HIDDEN_TIMEOUT=0 and GRUB_TIMEOUT=0 and I then ran sudo update-grub, to no avail.

The version on the GRUB menu says GNU GRUB version v2.02~beta2-9ubuntu1.14 if that helps at all, and if there's anything else that may be helpful just ask and I'll respond with it.

I searched around and couldn't find much on this topic.

Edit since OP wasn't clear enough:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Those are the pertinent settings currently in my /etc/default/grub, and I run sudo update-grub, which completes successfully it seems.

However, the GRUB menu still appears at boot.

Final edit for posterity:

None of the traditional solutions worked, I tried regenerating the grub file after ensuring that /etc/default/grub contained the proper information, to no avail.

What finally worked for me is entering the command:

grub-editenv create

as documented in this answer.

  • To elaborate the answer: grub on start reads /boot/grub/grub.cfg. The content of that file is autogenerated from /etc/default/grub, so what you were missing is forcing regeneration of the file. – Hi-Angel Nov 1 '17 at 21:25
3

Open /etc/default/grub with your favorite text editor. Make sure the following lines are not commented out or add them if they don't exist.

...
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
...

Finally run :

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.