Yesterday I upgraded from Ubuntu 17.04 to 17.10; it turns out that now I can't click on any elements that are directly GNOME-related: the Dock is dead, and the top panel also doesn't 'see' the mouse, doesn't react to clicks.

The login screen also doesn't react to clicking; the cursor moves just fine.

Inside most windows (Chrome, for instance), clicking is not a problem, and elements I've got lying about on the desktop can be clicked on and work.

The configuration window for the mouse works fine, scrolling and clicking are recognised inside that window, too.

Closing a window is possible only if the app has its own exit dialogue -the usual window operations don't work, apart from a few select apps, such as Chrome (but not Chromium).

I've tried with both my usual wireless mouse and a few wired ones -no difference at all.

As for the keyboard, inside the login screen it works perfectly, but then the number block 'dies', regardless of whether I press the NumBlock key.

I've got a strong feeling the two problems are related.


tells me "x11", so it's definitely not a Wayland issue.

I tried connecting two different cabled USB mice using an old PS/2 adapter. This did not work: the mice were simply not recognised. A cursor was visible but didn't move with the mouse.

Can anybody help me, please?

  • Sounds like a stuck key on the keyboard. Can you disconnect the keyboard (laptop too) and try an external keyboard? – heynnema Nov 1 '17 at 13:36
  • Thanks. I tried it, but no success. Also, both mouse and keyboard worked perfectly right until the reboot after the upgrade. – Joscha Finger Nov 1 '17 at 16:09
  • I tried two various suggestions at sourcedigit.com/… : reinstalling xserver-xorg-input-synaptics and setting GRUB to GRUB_CMDLINE_LINUX_DEFAULT=”i8042.reset quiet splash” . No change. – Joscha Finger Nov 1 '17 at 16:51
  • The output I get from less /proc/bus/input/devices is as follows: I: Bus=0003 Vendor=046d Product=c534 Version=0111 N: Name="Logitech USB Receiver" P: Phys=usb-0000:00:12.0-3/input1 S: Sysfs=/devices/pci0000:00/0000:00:12.0/usb3/3-3/3-3:1.1/0003:046D:C534.0002/i nput/input6 U: Uniq= H: Handlers=kbd mouse0 event3 B: PROP=0 B: EV=1f B: KEY=3007f 0 0 483ffff17aff32d bf54444600000000 ffff0001 130f938b17c000 677bfad941dfed 9ed68000004400 10000002 B: REL=1c3 B: ABS=100000000 B: MSC=10 – Joscha Finger Nov 1 '17 at 17:03
  • I got the mouse working doing the following: sudo ubuntu-drivers autoinstall . The keyboard issue still remains, though: it doesn't accept the BlockNum key's orders. – Joscha Finger Nov 1 '17 at 20:39

Summary for anyone having the same kind of problem: Most likely it's a driver issue, so run

sudo ubuntu-drivers autoinstall

in a terminal.

In Assistive Technlogies, Mouse Keys On means you can use the number block + another key I'm not really sure of to do the mouse's job, but in the act you disable the number block as such.

  • I think you mean Num Lock. – heynnema Nov 3 '17 at 22:22
  • Yup. Spanish keyboard... – Joscha Finger Nov 4 '17 at 11:52

This resolved it for me:

If you wish to do it permanently, edit

/etc/gdm3/custom.conf and uncomment the line:


Save the file and then on reboot you will never see the cog asking for which session to use.


Had the same issue, but I was definitely using Wayland. Changed it to X.org and it worked straight away. Ubuntu 17.10 with kernel 4.15.rc5

  • Same issue here. 'ubuntu-drivers autoinstall' didn't work unfortunately. – Enigma Jan 23 '18 at 3:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.