So like the subject I am trying to get vnc to work with Gnome. I have installed gnome and vncserver using the following command.

sudo apt install ubuntu-gnome-desktop
sudo apt-get install vnc4server

my xstartup file is as follows:


# Uncomment the following two lines for normal desktop:
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup.  
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey. 
#vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
gnome-session &

#metacity &
#gnome-settings-daemon &
#gnome-panel &
#nautilus &

I get a grey window.. I being trying based on the suggestions of google and yet no luck.. Though vnc server works or should I say the display shows up when I use XFCE.. but I am trying to use gnome(not classic)..

Please help..

UPDATE:could not figure out how to get vnc4server/vino to work.. But x11vnc worked just fine..

  • can you consider trying x2go? I find it faster and more reliable on ubuntu these days. Nov 1, 2017 at 19:57
  • yup.. tried that but I was had some problem even with that. I had issues with it starting on Mac.. so just gave up on immediately..
    – vinay
    Nov 4, 2017 at 18:05

1 Answer 1


Ubuntu comes with default remote sharing, to enable that just execute vino-preferences in terminal and enable remote sharing with password.

  • 1
    I did try this first.. But when I try to connect from the Mac with realvnc, it say connection refused.. Also I do get a GTK message: GTKdialog mapped without a transient parent. This is discouraged.
    – vinay
    Nov 1, 2017 at 12:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .