5

I upgraded my "acer aspire e13" laptop to lubuntu 17.10 (from 16.04, via 17.04) a few days ago and experience the following:

  • when booting with power cable plugged in, everything works.
  • whithout power cable, it doesn't start X11. Instead I can log in at the console. After logging in I get two or three messages about upgrade demon not being able to write a temporary file because the disk is mounted read only.

The battery is certainly fine, I can work for hours on it.

I don't even know where to start looking.

UPDATE - by request of Katu, here is the output of dmesg. I have still no clue.

15
  • Does the same thing happen in a live session?
    – steeef
    Nov 3 '17 at 21:49
  • If you mean: boot, unplug, reboot, the answer is yes. Nov 3 '17 at 21:52
  • I mean with an USB drive or CD.
    – steeef
    Nov 3 '17 at 21:53
  • No, sorry, I don't have one. I could possibly check next week. Is there any way to find out what specifically is going wrong? I guess no logfiles are being written due to the fs being read-only, right? Nov 3 '17 at 21:58
  • 1
    A live system run from USB or DVD would indeed be a quick and simple way to narrow down the possible sources of the issue. Nov 9 '17 at 19:11
1

I had the same problem after upgrading from Kubuntu 17.04 to Kubuntu 17.10. laptop-mode-tools was installed. Uninstalling it (apt remove laptop-mode-tools --purge) solved the issue.

0

From what I have gathered in my testing of this error on my machine is that the bios battery is failing, or in my case the battery is failing period.. I have lost 1/2 the cells.

A different error but related to a RO filesystem lead me to believe this is the case. I can't find that link as I was booted into a live instance. Pretty simple test. Plugged in. Booted x11. Didn't plug in. No x for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.