4

I have upgraded to artful recently and cannot install r-recommended any longer. I keep getting this error message:

user@box:~$ sudo apt install r-recommended 
[sudo] password for user:       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 r-recommended : Depends: r-cran-boot (>= 1.2.19) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
user@box:~$ 

Nonetheless, https://cran.r-project.org/bin/linux/ubuntu/artful/ is already available.

Edit: As asked by @muru in the comments, the output from sudo apt-get update plus the output from sudo apt-get upgrade were

user@box:~$ sudo apt update
Hit:1 http://download.virtualbox.org/virtualbox/debian zesty InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                
Ign:3 https://cran-r.c3sl.ufpr.br/bin/linux/ubuntu artful/ InRelease                                                                                                        
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                  
Hit:5 https://cran-r.c3sl.ufpr.br/bin/linux/ubuntu artful/ Release                                                                                                          
Hit:8 http://archive.ubuntu.com/ubuntu artful InRelease                                                                                                                     
Hit:9 http://archive.canonical.com/ubuntu artful InRelease              
Hit:10 http://archive.ubuntu.com/ubuntu artful-updates InRelease        
Hit:11 http://archive.ubuntu.com/ubuntu artful-backports InRelease
Hit:12 http://archive.ubuntu.com/ubuntu artful-security InRelease
Reading package lists... Done 
Building dependency tree       
Reading state information... Done
All packages are up to date.
user@box:~$ sudo apt upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
user@box:~$ 
2

There appears to be a broken dependency for r-cran-boot. Specifically, it depends on r-api-3, which no longer exists, having been changed to r-api-3.4.

sudo aptitude full-upgrade
The following packages will be upgraded:
  r-cran-boot{b} 
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 618 kB of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
 r-cran-boot : Depends: r-api-3 which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

 Keep the following packages at their current version:
1)     r-cran-boot [1.3-20-1build1 (artful, now)]         



Accept this solution? [Y/n/q/?] 

I'll try to submit a bug report presently.

Update: the package maintainer appears to have fixed the problem. I am able to upgrade without getting a dependency error.

  • Thanks, @user754850! I'm sorry to ask, but (sh|c)ould I do anything in the mean time, beyond sudo apt update && sudo apt install r-recommended every day until it installs by itself? – Marcelo Ventura Nov 1 '17 at 18:29
  • 1
    I'm not sure. I was fortunate enough to get r-cran-boot (and everything else) install, but I don't remember how I did it! I think that I used aptitude install r-base and then chose a solution that installed everything but left the r-api-3 dependency unsatisfied. – Paul Stodghill Nov 1 '17 at 18:42
  • Please, do try to submit a bug report. I tried, but wasn't able to deal with bugs.launchpad.net/ubuntu/+filebug – Marcelo Ventura Nov 2 '17 at 4:14
  • All I had to do was decline aptitude's first proposal, as I described in my answer below. Many thanks for your answer! =D – Marcelo Ventura Nov 2 '17 at 15:28
2

Indeed, as indicated by Paul Stodghill in his answer, installing with aptitude will do the trick as long as you know that it will propose first to install nothing -- one useless proposal you need to decline -- for, just then, it will propose to install r-cran-boot anyway with the unmet dependency on r-api-3.4, as seen in this output:

user@box:~$ sudo aptitude install r-recommended 
The following NEW packages will be installed:
  cdbs{a} dh-translations{a} intltool{a} libblas-dev{a} liblapack-dev{a} libncurses5-dev{a} libreadline-dev{a} libtinfo-dev{a} python-pkg-resources{a} python-scour{a} 
  python-six{a} r-base-core{a} r-base-dev{a} r-cran-boot{ab} r-cran-class{a} r-cran-cluster{a} r-cran-codetools{a} r-cran-foreign{a} r-cran-kernsmooth{a} 
  r-cran-lattice{a} r-cran-mass{a} r-cran-matrix{a} r-cran-mgcv{a} r-cran-nlme{a} r-cran-nnet{a} r-cran-rpart{a} r-cran-spatial{a} r-cran-survival{a} r-doc-html{a} 
  r-recommended 
0 packages upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
Need to get 43.5 MB of archives. After unpacking 78.9 MB will be used.
The following packages have unmet dependencies:
 r-cran-boot : Depends: r-api-3 which is a virtual package, provided by:
                        - r-base-core (3.4.2-2zesty), but 3.4.2-2artful4 is to be installed

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     r-cran-boot [Not Installed]                        
2)     r-recommended [Not Installed]                      

     Leave the following dependencies unresolved:         
3)     r-base-core recommends r-recommended               

Accept this solution? [Y/n/q/?] n

The following actions will resolve these dependencies:

     Install the following packages:        
1)     r-cran-boot [1.3-20-1build1 (artful)]

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  cdbs{a} dh-translations{a} intltool{a} libblas-dev{a} liblapack-dev{a} libncurses5-dev{a} libreadline-dev{a} libtinfo-dev{a} python-pkg-resources{a} python-scour{a} 
  python-six{a} r-base-core{a} r-base-dev{a} r-cran-boot{a} r-cran-class{a} r-cran-cluster{a} r-cran-codetools{a} r-cran-foreign{a} r-cran-kernsmooth{a} 
  r-cran-lattice{a} r-cran-mass{a} r-cran-matrix{a} r-cran-mgcv{a} r-cran-nlme{a} r-cran-nnet{a} r-cran-rpart{a} r-cran-spatial{a} r-cran-survival{a} r-doc-html{a} 
  r-recommended 
0 packages upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
Need to get 43.5 MB of archives. After unpacking 78.9 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 https://cloud.r-project.org/bin/linux/ubuntu artful/ r-base-core 3.4.2-2artful4 [23.2 MB]
Get: 2 https://cloud.r-project.org/bin/linux/ubuntu artful/ r-base-dev 3.4.2-2artful4 [4414 B]                                                                               
(...)
Setting up r-cran-rpart (4.1-11-1build1) ...
Setting up r-recommended (3.4.2-2artful4) ...

Current status: 1 (+1) upgradable.
user@box:~$ 
0

For users who come across this error in a different setting.

I had this on 18.04 after upgrading from 16.04.

I had another mirror on the 16.04 for cran. After the upgrade I had issues upgrading r-recommended with this same sort of output.

Once I had removed the source list, in my case cran.mirror.ac.za, the upgrade still didn't work with the output:

The following packages have unmet dependencies:

 r-cran-boot : Depends: r-api-3.4
 r-cran-class : Depends: r-api-3.4
 r-cran-cluster : Depends: r-api-3.4
 r-cran-codetools : Depends: r-api-3.4
 r-cran-foreign : Depends: r-api-3.4
 r-cran-kernsmooth : Depends: r-api-3.4
 r-cran-lattice : Depends: r-api-3.4
 r-cran-mass : Depends: r-api-3.4
 r-cran-matrix : Depends: r-api-3.4
 r-cran-mgcv : Depends: r-api-3.4
 r-cran-nlme : Depends: r-api-3.4
 r-cran-nnet : Depends: r-api-3.4
 r-cran-rpart : Depends: r-api-3.4
 r-cran-spatial : Depends: r-api-3.4
 r-cran-survival : Depends: r-api-3.4

I had to apt-get remove r-base-core, apt-get clean and then I could install r-recommended without an issue.

I think the issue was that the depended on package, r-base-core was installed from the other repo, and not automatically upgraded with the Ubuntu one.

This may actually have been the OP's situation, or can present the same in any case, so I thought may be a helpful answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.