9

I upgraded my ubuntu gnome installation to 16.04.3 LTS (GNOME) and everything is kinda good except for the touchpad single-tap functionality. Single-tap-to-click is not working.


Edit (by cipricus - in order to avoid creating a duplicate question): not only is it not working, but the setting presented in Gnome Help here (Open the Activities overview and start typing Mouse & Touchpad. - Click on Mouse & Touchpad to open the panel. - In the Touchpad section, check Tap to click.) is not applicable in Ubuntu Gnome 16.04, as the Touchpad section is simply absent there:

enter image description here

How come? I know this is already answered, but why is the Touchpad section absent? I will add a bounty for this.


2
  • thanks for the edit, the question is much more complete like this – smasper Nov 19 '17 at 23:40
  • I had the same problem on Ubuntu 18.04, and fixed it by going in the Devices section of the Settings GUI, and re-enabling the Tap to Click option – glS May 15 '18 at 11:39
20
+50

I've found a permanent solution with this command

gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true  

Gnome starting at 3.20 only allows configuring devices using the libinput driver. So if you are not using the libinput driver, it won't show up in the GUI.

Comment from discussion gnome 3.22 still does not detect tap to click?.

Additionally, GNOME may override certain behaviors, like turning off Tapping and forcing Natural Scrolling. In this case the settings must be adapted using GNOMEs gsettings command line tool or a graphical frontend of your choice. For example if you wish to enable Tapping and disable Natural Scrolling for your user, adjust the touchpad key-values like the following:

gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true  

https://wiki.archlinux.org/index.php/Libinput#Touchpad_not_working_in_GNOME

3
  • great, trying Gnome 3 for the first time and my only hope is askubuntu. – user47206 Nov 17 '17 at 20:36
  • I am having the same problem with my Ubuntu 16.04 installation. I ran 'gsettings list-recursively org.gnome.desktop.peripherals.touchpad' and tap to click is set to true, (result: 'org.gnome.desktop.peripherals.touchpad tap-to-click true') but yet it doesn't work. The tap-to-click checkbox in the settings (Gnome 3) is set true as well. Any ideas? – Caio Mar Mar 21 '18 at 15:45
  • I have had this problem no matter what I try. None of the solutions here work for more than a few seconds. I have a script that runs gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true over and over again but even that fails and needs to be restarted. very frustrating. – Robert Baker Aug 2 '19 at 19:05
9

In 18.04 (with Unity 7) I had to install the synaptics driver:

sudo apt install xserver-xorg-input-synaptics
3
  • 1
    Thanks! This resolved it for me in KDE and XFCE on 18.04 as well, on my Dell XPS 15z – cleary Aug 31 '18 at 0:06
  • 1
    This resolved the issue for me on a Thinkpad X1 Carbon running Ubuntu 18.10 with Unity. – Jason McVetta May 14 '19 at 5:57
  • 1
    using ubuntu 20.04 and it also works. thanks. – ssi-anik Feb 12 at 15:32
-1

I have created a script to automate this process. It will be automatically started when the system starts. So, you don't have to run the same command again and again. The link of the script is github.com/Ryko-git/click-on-touchpad .

The installation process is very easy. It is given on the github page.

1
  • Can you please elaborate the reason behind the down vote. If it does not work please tell me, I will check it. My friend had similar problem this script solved his problem. – Ryko May 2 '18 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.