0

Anyone can help me please.

I just want to install letsencrypt, then i use the common command like sudo apt-get update && apt-get upgrade. But it return error to me, and it lets me try apt-get -f install.

I can not use apt-get -f install.

Thanks for your advice.

enter image description here

  • What exactly did you tried to install before noticing this error? If you were following a guide/tutorial, please edit and post it. – user692175 Nov 1 '17 at 4:44
  • I just want to install letsencrypt, then i use the common command like sudo apt-get update && apt-get upgrade. But it return error to me, and it lets me try apt-get -f install. – Sittisak Po-ngam Nov 1 '17 at 4:48
  • apt-get -f install is something you wouldn't normally use/need. If you do then there's a problem. Please edit again and describe exaclty what you did before getting this error. – user692175 Nov 1 '17 at 5:03
-1

please try:

 `sudo rm /var/cache/apt/archive/lock`
 `sudo dpkg--cofigure -a`

I had same problem and they worked for me

  • same error, but thanks for your kindly. – Sittisak Po-ngam Nov 1 '17 at 4:31
  • 2
    Like medicine, what works for you often does not for others. In this case this couldn't work because it has nothing to do with the problem: This removes a lock (which doesn't exist, apt works but gives errors) yet the problem is at the software sources. – user692175 Nov 1 '17 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.