5

After upgrading to Ubuntu 17.10, Ubuntu Dock icons of some of my apps are not appearing. They appear properly in the dash. I verified the *.desktop files for the applications in /usr/share/applications and ~/.local/share/applications.

E.g. dock icon is not displaying for "Terminator". Check out the attached image.

enter image description here

This is how the icon for the same application appears in dash search:

enter image description here

Content of /usr/share/applications/terminator.desktop:

[Desktop Entry]
Name=Terminator
Comment=Multiple terminals in one window
TryExec=terminator
Exec=terminator
Icon=terminator
Type=Application
Categories=GNOME;GTK;Utility;TerminalEmulator;System;
StartupNotify=true
X-Ubuntu-Gettext-Domain=terminator
X-Ayatana-Desktop-Shortcuts=NewWindow;
Keywords=terminal;shell;prompt;command;commandline;
[NewWindow Shortcut Group]
Name=Open a New Window
Exec=terminator
TargetEnvironment=Unity

Any pointers to debug this issue will be helpful.

  • Did you tried reinstalling Terminator? – lapisdecor Oct 31 '17 at 17:53
  • @lapisdecor I did try reinstalling terminator. doesn't help. – chaudharyp Oct 31 '17 at 18:02
  • 1
    Removing the icon from the laucher and using add to favorites from the dash doesn't solve it? – lapisdecor Oct 31 '17 at 18:07
  • @lapisdecor that helps! there is an issue though. I've configured Ctrl + Alt + T to open terminator instead of gnome-terminal. Even if I "Add To Favorites", a new terminator app is launched on Ctrl + Alt + T with the wrong icon. – chaudharyp Oct 31 '17 at 18:13
  • I can have a workaround for it by keeping "terminator" as a startup application. After all, I would always require a terminal. That is just a hack and doesn't solve the internal problem though. – chaudharyp Oct 31 '17 at 18:18
7

Try this method in an Xorg session, not sure whether it would work in a Wayland session.

  1. Launch one such application, say Terminator, whose correct icon is not seen in Ubuntu Dock.
  2. Run xprop WM_CLASS in Terminal. The cursor should turn into a crosshair.
  3. Place the crosshair over Terminator and click. You should get a WM_CLASS string for Terminator.
  4. Open Terminator's .desktop file and add the following line

    StartupWMClass=OBTAINED-VALUE
    

    In place of OBTAINED-VALUE put a value you got from step 3 without any quotes.

  5. Save the .desktop file.

| improve this answer | |
  • I think it might work in Wayland too, at least for apps running under XWayland. – pomsky Oct 31 '17 at 19:50
  • 1
    Adding StartupWMClass using the method you told doesn't fix the issue in the Wayland session(default on 17.10). In fact, StartupWMClass is not even required for an Xorg session. The icons work fine on Xorg session without this fix. The issue is with Wayland session then. – chaudharyp Nov 1 '17 at 5:10
  • 1
    I had this issue in both sessions, wayland and xorg. But @pomsky 's instruction solved the problem for both sessions. – eDeviser Dec 12 '17 at 6:35
  • The problem is that the curson only turns into a crosshair in the desktop, if i place it on any window it will change back in to the normal cursor, not letting me see the class. – Maxrunner Mar 14 '18 at 11:59
  • @Maxrunner Should not be "any" window, only apps running under Wayland instead of XWayland (Hint: try with Firefox, it should work). To get it work with all windows,switch back to Xorg session from the default Wayland session. – pomsky Mar 14 '18 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.