0

Full upgrade stopped with error "Could not calculate the upgrade". I opened var/log/dist-upgrade/main.log and there was problem with unity (could not remove it, because it was blacklisted) so I removed unity manualy (recommendation from forum). After that I run software update again and it gave me option for partial upgrade.

After I did partial upgrade to ubuntu 17.10 I had to restart computer. It gets past GRUB menu and after that stucks while showing (blinking) "Ubuntu:clean, 998941/2949120 files, 8509242/11796480 blocks". Sometimes it shows additional row "ubuntu:recovering journal".

I tried chosing Advanced Option, Recovery mode, Root and typed sudo fsck -f / . I get message "Superblock last write time is in the future. (by less than a day, probably due to the hardware clock being incorrectly set)". Then I get Pass 1 to 5, all Checking different things and in the end "Ubuntu: 998916/2949120 files (0.6% non-contiguous), 8509840/11796480 blocks".

Update: I edited grub file (removed quiet and added nomodeset) and this is photo of booting process when it stucks: https://www.dropbox.com/s/4qvlymlzufkd2j5/IMG_20171102_211651.jpg?dl=0

Update: I can get to terminal with multiple time hitting ctrl+alt+F1

@panther: I managed to run live DVD and did fsck (no error) and SMART self-test (in Disks) - it completed successfully. So I guess I'm ok. Should I reinstall 17.10 from the same live DVD? Will I not lose my /home folder, my old data,...?

7
  • 1
    'partial upgrade' usually means your system isn't really upgraded and stuck somewhere between the versions. Did it give you an error as to why the upgrade failed? – Thomas Ward Oct 31 '17 at 16:04
  • What is a "partial upgrade" ? Sounds bad right there. Partial upgrades can be difficult or impossible to fix. In addition it sounds as if your file system is corrupted, this could indicate a hardware problem. You should be running fsck from a live image, not from recovery mode. I suggest booting a 17.10 flash drive, run fsck from the live image, and check your hard drive for problems with smartctl - help.ubuntu.com/community/Smartmontools . If your hard drive is OK probably best to do a fresh install. – Panther Oct 31 '17 at 16:13
  • Please run fsck and smartmontools from a live usb and post the output. – Panther Oct 31 '17 at 16:27
  • I could not do that. Had ubuntu image on my usb, changed boot priorities in BIOS menu, but after that I got another "boot menu" in which I had to confirm booting from usb, but my keyboard did not work in that menu. – Mersault Oct 31 '17 at 21:46
  • Please can sameone help me? Maybe there is something wrong with my graphics drivers (suggestions from other forums)? How can I check, what is wrong? – Mersault Nov 2 '17 at 17:38
0

This issue was resolved by updating latest kernel. Basically this is a kernel issue. Updating kernel will not only resolve this issue but also resolve issue of wireless network and booting issue. It will also resolve boot screen stuck issue and terminal stuck issue Follow below steps to update your kernel in Ubuntu 17.10:

  1. Navigate to below URL: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13.10/ and download all five kernel release in a single directory given below (For intelx64 & Amdx64 systems only):

linux-headers-4.13.10-041310_4.13.10-041310.201710270531_all.deb linux-headers-4.13.10-041310-generic_4.13.10-041310.201710270531_amd64.deb linux-headers-4.13.10-041310-lowlatency_4.13.10-041310.201710270531_amd64.deb linux-image-4.13.10-041310-generic_4.13.10-041310.201710270531_amd64.deb linux-image-4.13.10-041310-lowlatency_4.13.10-041310.201710270531_amd64.deb

  1. Install using below command: $ cd /path/to/folder/where/you/put/the/debs $ sudo dpkg -i *.deb

  2. Now reboot your system and boot with latest kernel at the time of system startup using boot menu.

This will definitely resolve your issue. Cheers :)

1
  • So if I do that, will I get my old user profile back? Because now I reinstalled 17.10 with new user name (I have to manually get all things sorted out like in my old profile). My old user profile is saved in another partition. So if I save my old profile back will it work with upgraded 17.10? – Mersault Nov 4 '17 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.