Here is the thing: I've been using the same laptop, with the same HP LaserJet P3010 Series, with the same OS (Ubuntu 14.04, 32 or 64 bit, MATE desktop) for over a year, and the same Device URI hp:/usb/HP_LaserJet_P3010_Series?serial=XXXX in system-config-printer, and I had no problems whatsoever.

Something changed in the past few months, which broke the printing process somewhat - but I really cannot tell what, because I meet this problem only when I have to print, which is about once a month.

So this is what I experience now - I connect printer via USB, and turn it on; everything looks good on printer, and system-config-printer status (Printer State) does not complain (sometimes it is "Idle", sometimes "Idle - ready to print", sometimes blank - but that is how it was when it was working too).

Then, I open my.pdf in evince, and try to print. No page comes out; when I right-click on the printer icon in system-config-printer and choose "View print queue), I get the document listed, but with status "Pending", which doesn't change for minutes. I've seen this:

Printer in "pending" mode only, not printing

Under Settings>Printers>Policies "Enabled" was not selected

... but I cannot find "Settings" on my OS anywhere (there is System/Preferences and System/Administration); but that answer is also for Ubuntu 13. Then I found this:

CUPS. Printer "pending" mode

... restarting CUPS with the command "sudo service cups restart". ...

... and indeed, after sudo service cups restart, the document gets sent to the printer, disappears from the queue - but the printer prints blank page! I found this as a possible explanation for the problem:

The network printer will only print blank pages and will not stop. What should I do?

Looks like you-re sending postscript directly to the printer, which may not understand it, that's why it spits blank pages.

So, I make a test from the system-config-printer properties of the printer, and print a test page - it prints fine. Printing again from evince either gets stuck at "Pending", or prints a blank page. Then I found advice like on:


Can you print a single page PDF successfully via the lpr command?
lpr -P <printer_name> /path/to/sample.pdf

And so I tried lpr (without the -P argument, since this is the only active printer on my system at the time, and it is set as default):

lpr my.pdf

... and now it works - the print is fine!?

I guess this problem is somewhat similar to PDF viewer prints blank pages ... But what could have been the problem that changed the otherwise working procedure to this?

Also, since this is an HP printer, in some posts that I read, they recommend some HP utilities, and it turns out (just noticed today), I do have System/Preferences/HPLIP Toolbox (I guess, it is /usr/bin/hp-toolbox); were some settings changed here, or on the CUPS level, or elsewhere? How would I troubleshoot this problem?

2 Answers 2


I have faced a similar problem sometimes back. I was on a network and my printer was printing only blank sheets. Later I found out that one of the network clients was using the same IP address as that of the printer and so there was a conflict of IP addresses. It took a long time to find out this issue but finally its resolved now.

  • 1
    Thanks for noting this - however, the post (maybe not very clearly) notes hp:/usb... meaning this is a USB printer, and so conflict of IP addresses is not applicable here (though a good tip to know in general)
    – sdaau
    Jan 18, 2018 at 13:19

Well, I had to print again, again had the same problem, and I found this:

most of the time it says "Pending" and will not print. I went into Ubuntu and the Policies is Enabled...What else can I try?

If HP, I find I have to go into hp, hp device manager, printer control, & start printer. Not sure why it gets turned off.

Well, I thought I'd try that, and I guess when I print/connect an HP printer, I get an HP icon in the desktop top panel, and when I click on the applet, I get a menu, from where I clicked "HP Device Manager..." - but it told me /usr/bin/hp-toolbox cannot be found. It turns out it is in sudo apt-get install hplip-gui on Ubuntu 14.04, so after installing that, I could show the device manager, which at first didn't detect* the printer, but after restarting* the printer it did, and printing was fine. Maybe because that Device Manager was started, some state got refreshed in the system regarding the printer, and so it started properly printing directly from evince again.

* I've just recently noted, that an old USB mouse I have, interferes with detection of newer USB devices, if it is plugged in in an external USB hub first, before the newer USB devices. So, I had to turn off printer, remove the USB mouse, and turn on printer again, and this time the detection was successful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.