1

SEE UPDATES BELOW

I recently upgraded from Ubuntu 17.04 to Ubuntu 17.10 using the software update process. The update completed without any errors, and Ubuntu 17.10 is now running without any major issues.

However, I was running a script previously that uses rtcwake which has since stopped working. The script automatically hibernates my laptop after a set period of time in sleep mode, and was working perfectly in Ubuntu 17.04.

In the process of troubleshooting, I discovered that the problem was with rtcwake which is complaining about /dev/rtc0 missing.

Here is output from a sample rtcwake command:

peter@haven:~$ rtcwake -m no -s 1300
rtcwake: assuming RTC uses UTC ...
rtcwake: /dev/rtc0: unable to find device: No such file or directory

I verified that in fact, that directory is missing. Since this was working prior to the upgrade, I have to assume that it was there previously, but I don't know for sure.

In researching the error, I found some suggestions to get further information with timedatectl and hwclock, so here are the results from those commands as well.

Output of timedatectl:

peter@haven:~$ timedatectl
      Local time: Fri 2017-10-27 19:06:26 EDT
  Universal time: Fri 2017-10-27 23:06:26 UTC
        RTC time: n/a
       Time zone: America/New_York (EDT, -0400)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

Output of hwclock --debug:

peter@haven:~$ sudo hwclock --debug
[sudo] password for peter: 
hwclock from util-linux 2.30.1
Trying to open: /dev/rtc0
Trying to open: /dev/rtc
Trying to open: /dev/misc/rtc
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

Has anyone else experienced any similar issues since upgrading? If not, please offer any suggestions how best to proceed with my troubleshooting.

UPDATE

When I boot with my old kernel, 4.10.0-37-generic the real-time clock works fine.

I get the following RTC messages in dmesg when I boot the 4.13.0-16-generic kernel:

peter@haven:~$ dmesg | grep -i rtc
[    0.089393] RTC time: 17:03:55, date: 11/01/17
[    1.238784] rtc_cmos 00:01: RTC can wake from S4
[    1.238794] rtc_cmos: probe of 00:01 failed with error -16
[    1.295459] hctosys: unable to open rtc device (rtc0)

UPDATE #2

Well, I was starting to believe that I had a hardware issue, since discovering I was unable to save changes to my BIOS and could not boot from USB. As it turns out, my laptop was bitten by this bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147 causing my BIOS to be locked in a read-only state.

Once I resolved the BIOS issue, and fixed the USB boot problem, I did a live boot of Ubuntu 17.10. The issue with my real time clock still exists under this clean boot scenario, yet when I boot other distros, like Linux Mint 18.3 and the real time clock works fine. I feel this definitely has something to do with the Ubuntu install, perhaps even a kernel bug.

UPDATE #3

More evidence to suggest this is a kernel bug: I live-booted a copy of Antergos Linux, which was using the Arch kernel 4.14.12-1-ARCH and it exhibited the same problem with the real time clock as Ubuntu 17.10. In addition, I confirmed that the Linux Mint version I booted earlier (see Update #2) was on the Ubuntu kernel 4.10.0-38-generic.

So, I suspect that sometime between kernels 4.10 and 4.13 this bug was introduced. Can anyone provide me with information for filing a kernel bug?

UPDATE Jan. 30, 2018

Kernel bug reported on Launchpad (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1743027) and with upstream kernel developers.

  • linuxquestions.org/questions/linux-hardware-18/… led me to linuxforums.org/forum/kernel/149704-dev-rtc-doesnt-exist.html which says to run make menuconfig, but this is from a while ago and another flavor, so I'm not sure how relevant it is. EDIT also this serverfault.com/a/852008 – brndn2k Oct 31 '17 at 15:36
  • @brndn2k, I did follow the suggestions in the links you provided, but they did not work for me. Although I did not run make menuconfig I validated that the relevant options for RTC were enabled in my existing kernel config. – pbmilley Oct 31 '17 at 20:43
  • I am also affected by this on Linux 4.14.14 self compiled on Slackware 14.2. My system is a laptop Fujitsu A555 ($ inxi -v 1 System: Host: slackware Kernel: 4.14.14 x86_64 bits: 64 Desktop: Xfce 4.12.4 Distro: Slackware 14.2 CPU: Dual core Intel Core i3-5005U (-MT-MCP-) speed/max: 1423/1900 MHz Drives: HDD Total Size: 1000.2GB (53.1% used) Info: Processes: 172 Uptime: 5 days Memory: 5276.0/11917.1MB Client: Shell (bash) inxi: 2.3.53). @pbmilley it might be useful to post your system specs and a link to your launchpad bug report. – aaditya1234 Jan 26 '18 at 15:21
  • @AadityaBagga, thanks for confirming the issue. I've taken your suggestion and added the link to my Launchpad bug report in the description. And here is my system info: – pbmilley Jan 30 '18 at 20:14
  • System: Host: haven Kernel: 4.13.0-31-generic x86_64 bits: 64 Desktop: Gnome 3.26.2 Distro: Ubuntu 17.10 CPU: Dual core Intel Core i7-4510U (-HT-MCP-) speed/max: 2593/3100 MHz Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller Display Server: wayland (X.Org 1.19.5 ) drivers: modesetting (unloaded: fbdev,vesa) Resolution: 1920x1080@60.05hz OpenGL: renderer: Mesa DRI Intel Haswell Mobile version: 4.5 Mesa 17.2.4 – pbmilley Jan 30 '18 at 20:14
0

This has been confirmed as a bug in the Linux kernel (follow the status of the bug here: https://bugzilla.kernel.org/show_bug.cgi?id=199033).

A workaround is to custom configure the kernel, using make menuconfig, and disable support for the CONFIG_WDAT_WDT driver. This removes the conflict with the RTC driver and allows it to run normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.