2

I had a USB keyboard connected through a KVM switch (keyboard, video, mouse) to an Ubuntu Server. Then I had to remove the KVM and then I've connected a PS/2 keyboard to the server. Now I can't type into the terminal. But I still can switch TTY by pressing Ctrl + Alt + F2 (or F3, F4) but the login screen does not appear there only a blinking cursor. I can also return to TTY 1 (Ctrl + Alt + F1).

That's what the terminal shows:

enter image description here

I can SSH into the server no problem. The question is how can I make the keyboard work without restarting the server?

  • So the keyboard does work, you're using the PS/2 keyboard to hit Ctrl+Alt+F1, right? It just only works for that and doesn't let you type? That's very odd, but PS/2 is an old standard and, if I remember correctly, you couldn't hot plug it. Not the way you can with USB, anyway. You might want to try and reload the kernel module that deals with it. Does sudo modprobe -r atkbd; sudo modprobe atkbd help by any chance? – terdon Oct 31 '17 at 14:19
  • @terdon I get modprobe: FATAL: Module atkbd is builtin.. I tried 2 USB keyboards too by the way, but it works the same. – Dmitry Oct 31 '17 at 14:28
  • Yes, USB would. I haven't used PS/2 in many, many years, but I don't remember that it was possible to just plug something into a running machine and have it detected. You haven't hit Ctrl+S by mistake, y any chance? Does pressing Ctrl+Q or Ctrl+C let you type? If not, and if rebooting is really not an option, it might be simpler to just get a very cheap USB keyboard and use that instead. – terdon Oct 31 '17 at 14:46
  • I tried USB keyboards with the same result. I did not press Ctrl+Q or C or S on purpose but the problem is that when I had KVM when I was switching to/from Linux server it was dumping some garbage to the console. So that could have broken it. – Dmitry Oct 31 '17 at 15:03
  • 1
    I have no idea what KVM is, for me that's a well known virtualization platform, but you're clearly referring to something else. – terdon Oct 31 '17 at 15:18
0

PS/2 is not a hot plug device and in some cases, when certain jumpers and BIOS settings enable continuous power supply to those devices even when the computer is off, just switching off the computer is not enough. You also have to unplug the power cord, in order to add or remove one, keyboard or mouse. I am using a PS/2 keyboard and this is the way to have it detected properly by both the BIOS and the kernel.

That said, it's self explanatory what you need to do.

  • Thanks for reply. But it's clearly not a problem with the PS/2 or the keyboard itself, because I tried USB keyboards with the same result. I can switch TTYs and I can wake up the monitor when it turns off. It looks more like the server stopped accepting input from the terminal and it only dumps system messages there. – Dmitry Oct 31 '17 at 16:48
  • @Dmitry and yet hitting Ctrl+C doesn't make any difference? Really? – terdon Oct 31 '17 at 17:22
  • I tried hitting ctrl+c and ctrl +z but it did not work. I'm not at work right now, I'll try again tomorrow. – Dmitry Oct 31 '17 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.